http-conduit: HTTP client package with conduit interface and HTTPS support.

[ bsd3, conduit, library, web ] [ Propose Tags ]

This package uses attoparsec for parsing the actual contents of the HTTP connection. It also provides higher-level functions which allow you to avoid direct usage of conduits. See http://www.yesodweb.com/book/http-conduit for more information.

Versions [faq] 1.0.0, 1.0.0.1, 1.1.0, 1.1.0.1, 1.1.1, 1.1.2.2, 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4, 1.2.5, 1.2.6, 1.3.0, 1.3.0.1, 1.4.0, 1.4.0.1, 1.4.0.2, 1.4.1, 1.4.1.1, 1.4.1.2, 1.4.1.3, 1.4.1.4, 1.4.1.5, 1.4.1.6, 1.4.1.7, 1.4.1.8, 1.4.1.9, 1.4.1.10, 1.5.0, 1.5.0.1, 1.5.0.2, 1.5.0.3, 1.6.0, 1.6.0.1, 1.6.0.2, 1.6.0.3, 1.6.0.4, 1.6.1, 1.6.1.1, 1.6.1.2, 1.7.0, 1.8.0, 1.8.1, 1.8.2, 1.8.2.1, 1.8.3, 1.8.4, 1.8.4.1, 1.8.4.2, 1.8.4.3, 1.8.4.4, 1.8.4.5, 1.8.5, 1.8.5.1, 1.8.5.2, 1.8.6, 1.8.6.1, 1.8.6.2, 1.8.6.3, 1.8.7, 1.8.7.1, 1.8.8, 1.8.9, 1.9.0, 1.9.1, 1.9.2, 1.9.2.1, 1.9.2.2, 1.9.3, 1.9.4, 1.9.4.1, 1.9.4.2, 1.9.4.3, 1.9.4.4, 1.9.4.5, 1.9.5, 1.9.5.1, 1.9.5.2, 1.9.5.3, 1.9.6, 2.0.0, 2.0.0.1, 2.0.0.2, 2.0.0.3, 2.0.0.4, 2.0.0.5, 2.0.0.6, 2.0.0.7, 2.0.0.8, 2.0.0.9, 2.0.0.10, 2.1.0, 2.1.1, 2.1.2, 2.1.2.1, 2.1.2.2, 2.1.2.3, 2.1.3, 2.1.4, 2.1.4.1, 2.1.4.2, 2.1.4.3, 2.1.4.4, 2.1.4.5, 2.1.4.7, 2.1.5, 2.1.5.1, 2.1.6, 2.1.7, 2.1.7.1, 2.1.7.2, 2.1.8, 2.1.9, 2.1.10, 2.1.10.1, 2.1.11, 2.2.0, 2.2.0.1, 2.2.1, 2.2.2, 2.2.2.1, 2.2.3, 2.2.3.1, 2.2.3.2, 2.2.4, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.3.5, 2.3.6, 2.3.6.1, 2.3.7, 2.3.7.1
Dependencies asn1-data (>=0.5.1 && <0.7), attoparsec (>=0.8.0.2 && <0.11), attoparsec-conduit (==0.5.*), base (==4.*), base64-bytestring (==0.1.*), blaze-builder (>=0.2.1 && <0.4), blaze-builder-conduit (==0.5.*), bytestring (>=0.9.1.4 && <0.10), case-insensitive (>=0.2), certificate (==1.2.*), conduit (==0.5.*), containers (>=0.2), cookie (==0.4.*), cprng-aes (==0.2.*), data-default, deepseq, failure (>=0.1), http-types (>=0.6 && <0.8), lifted-base (==0.1.*), monad-control (==0.3.*), mtl, network (>=2.2.1 && <2.2.3 || ==2.3.*), network-bytestring (==0.1.3.*), regex-compat, resourcet (==0.3.*), socks (==0.4.*), text, time, tls (>=0.9.3 && <0.10), tls-extra (>=0.4.5 && <0.5), transformers (>=0.2 && <0.4), transformers-base (==0.4.*), utf8-string (>=0.3.4 && <0.4), void (>=0.5.5 && <0.6), zlib-conduit (==0.5.*) [details]
License BSD-3-Clause
Author Michael Snoyman <michael@snoyman.com>
Maintainer Michael Snoyman <michael@snoyman.com>
Category Web, Conduit
Home page http://www.yesodweb.com/book/http-conduit
Source repo head: git clone git://github.com/snoyberg/http-conduit.git
Uploaded by MichaelSnoyman at Tue Jul 10 07:40:34 UTC 2012
Distributions Arch:2.3.7.1, Debian:2.3.2, Fedora:2.3.2, FreeBSD:2.1.8, LTSHaskell:2.3.7.1, NixOS:2.3.7.1, Stackage:2.3.7.1, openSUSE:2.3.7.1
Downloads 206476 total (3154 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
network-bytestringDisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees