imperative-edsl: Deep embedding of imperative programs with code generation

[ bsd3, language, library ] [ Propose Tags ]

Deep embedding of imperative programs with code generation.

The main module for users who want to write imperative programs is Language.Embedded.Imperative.

Examples can be found in the examples directory.

Versions [faq] 0.4.1, 0.5, 0.6, 0.7, 0.7.1, 0.8
Dependencies array, base (==4.*), BoundedChan, containers, data-default-class, deepseq, directory, exception-transformers, ghc-prim, language-c-quote (>=0.11.5 && <0.12), mainland-pretty (>=0.4 && <0.6), microlens (>=0.3.0.0), microlens-mtl (>=0.1.8), microlens-th, mtl, operational-alacarte (>=0.3), process, srcloc, stm (==2.4.*), syntactic (>=3.2), time (>=1.5.0.1) [details]
License BSD-3-Clause
Copyright Copyright (c) 2016 Anton Ekblad, Emil Axelsson, Máté Karácsony Copyright (c) 2015 Anders Persson, Anton Ekblad, Emil Axelsson, Markus Aronsson, Josef Svenningsson
Author Anders Persson, Emil Axelsson, Markus Aronsson
Maintainer 78emil@gmail.com
Revised Revision 2 made by EmilAxelsson at 2017-03-06T11:16:07Z
Category Language
Home page https://github.com/emilaxelsson/imperative-edsl
Bug tracker https://github.com/emilaxelsson/imperative-edsl/issues
Source repo head: git clone git@github.com:emilaxelsson/imperative-edsl.git
Uploaded by EmilAxelsson at 2016-08-25T15:09:44Z
Distributions NixOS:0.8
Downloads 3452 total (8 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2016-08-25 [all 1 reports]

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees