Build #1 for language-oberon-0.2.1

[all reports]

Package language-oberon-0.2.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2019-01-27 20:05:14.577579822 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, containers-0.6.0.1, directory-1.3.3.0, either-5.0.1, filepath-1.4.2.1, grammatical-parsers-0.3.2, parsers-0.12.9, prettyprinter-1.2.1, rank2classes-1.2, template-haskell-2.14.0.0, text-1.2.3.1, transformers-0.5.5.0, base-4.12.0.0, containers-0.6.0.1, either-5.0.1, filepath-1.4.2.1, grammatical-parsers-0.3.2, optparse-applicative-0.14.3.0, prettyprinter-1.2.1, rank2classes-1.2, repr-tree-syb-0.1.1, text-1.2.3.1
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     StateVar-1.1.1.1
Starting     cabal-doctest-1.0.6
Starting     base-orphans-0.8
Starting     colour-2.3.4
Building     StateVar-1.1.1.1
Building     base-orphans-0.8
Building     cabal-doctest-1.0.6
Building     colour-2.3.4
Completed    base-orphans-0.8
Starting     hashable-1.2.7.0
Completed    StateVar-1.1.1.1
Starting     integer-logarithms-1.0.2.2
Building     hashable-1.2.7.0
Building     integer-logarithms-1.0.2.2
Completed    cabal-doctest-1.0.6
Starting     prettyprinter-1.2.1
Building     prettyprinter-1.2.1
Completed    integer-logarithms-1.0.2.2
Starting     primes-0.2.1.0
Building     primes-0.2.1.0
Completed    hashable-1.2.7.0
Starting     primitive-0.6.4.0
Building     primitive-0.6.4.0
Completed    primes-0.2.1.0
Starting     semigroups-0.18.5
Completed    colour-2.3.4
Starting     syb-0.7
Building     semigroups-0.18.5
Building     syb-0.7
Completed    semigroups-0.18.5
Starting     tagged-0.8.6
Building     tagged-0.8.6
Completed    prettyprinter-1.2.1
Starting     th-abstraction-0.2.10.0
Building     th-abstraction-0.2.10.0
Completed    syb-0.7
Starting     transformers-compat-0.6.2
Completed    tagged-0.8.6
Starting     contravariant-1.5
Building     transformers-compat-0.6.2
Building     contravariant-1.5
Completed    th-abstraction-0.2.10.0
Starting     unordered-containers-0.2.10.0
Completed    transformers-compat-0.6.2
Starting     ansi-terminal-0.9
Building     unordered-containers-0.2.10.0
Completed    contravariant-1.5
Downloading  repr-tree-syb-0.1.1
Downloaded   repr-tree-syb-0.1.1
Starting     repr-tree-syb-0.1.1
Building     ansi-terminal-0.9
Building     repr-tree-syb-0.1.1
Completed    repr-tree-syb-0.1.1
Starting     distributive-0.6
Completed    ansi-terminal-0.9
Starting     ansi-wl-pprint-0.6.8.2
Completed    primitive-0.6.4.0
Starting     vector-0.12.0.2
Building     ansi-wl-pprint-0.6.8.2
Building     vector-0.12.0.2
Building     distributive-0.6
Completed    ansi-wl-pprint-0.6.8.2
Starting     scientific-0.3.6.2
Completed    distributive-0.6
Starting     optparse-applicative-0.14.3.0
Building     scientific-0.3.6.2
Building     optparse-applicative-0.14.3.0
Completed    unordered-containers-0.2.10.0
Downloading  rank2classes-1.2
Downloaded   rank2classes-1.2
Starting     rank2classes-1.2
Building     rank2classes-1.2
Completed    scientific-0.3.6.2
Starting     comonad-5.0.4
Building     comonad-5.0.4
Completed    optparse-applicative-0.14.3.0
Starting     charset-0.3.7.1
Building     charset-0.3.7.1
Completed    rank2classes-1.2
Starting     attoparsec-0.13.2.2
Building     attoparsec-0.13.2.2
Completed    comonad-5.0.4
Starting     bifunctors-5.5.3
Building     bifunctors-5.5.3
Completed    charset-0.3.7.1
Completed    attoparsec-0.13.2.2
Starting     parsers-0.12.9
Building     parsers-0.12.9
Completed    bifunctors-5.5.3
Starting     profunctors-5.3
Starting     semigroupoids-5.3.2
Building     profunctors-5.3
Building     semigroupoids-5.3.2
Completed    parsers-0.12.9
Completed    vector-0.12.0.2
Downloading  monoid-subclasses-0.4.6.1
Downloaded   monoid-subclasses-0.4.6.1
Starting     monoid-subclasses-0.4.6.1
Building     monoid-subclasses-0.4.6.1
Completed    profunctors-5.3
Completed    semigroupoids-5.3.2
Starting     either-5.0.1
Building     either-5.0.1
Completed    either-5.0.1
Completed    monoid-subclasses-0.4.6.1
Downloading  grammatical-parsers-0.3.2
Downloaded   grammatical-parsers-0.3.2
Starting     grammatical-parsers-0.3.2
Building     grammatical-parsers-0.3.2
Completed    grammatical-parsers-0.3.2
Downloading  language-oberon-0.2.1
Downloaded   language-oberon-0.2.1
Starting     language-oberon-0.2.1
Building     language-oberon-0.2.1
Failed to install language-oberon-0.2.1
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/language-oberon-0.2.1-KfHXSSwkxOwYFLmRmZuF1.log ):
cabal: Entering directory '/tmp/cabal-tmp-1774/language-oberon-0.2.1'
Configuring language-oberon-0.2.1...
Preprocessing library for language-oberon-0.2.1..
Building library for language-oberon-0.2.1..
[ 1 of 11] Compiling Transformation   ( src/Transformation.hs, dist/build/Transformation.o )
[ 2 of 11] Compiling Transformation.Deep ( src/Transformation/Deep.hs, dist/build/Transformation/Deep.o )
[ 3 of 11] Compiling Transformation.AG ( src/Transformation/AG.hs, dist/build/Transformation/AG.o )
[ 4 of 11] Compiling Transformation.Deep.TH ( src/Transformation/Deep/TH.hs, dist/build/Transformation/Deep/TH.o )
[ 5 of 11] Compiling Language.Oberon.AST ( src/Language/Oberon/AST.hs, dist/build/Language/Oberon/AST.o )
[ 6 of 11] Compiling Language.Oberon.TypeChecker ( src/Language/Oberon/TypeChecker.hs, dist/build/Language/Oberon/TypeChecker.o )

src/Language/Oberon/TypeChecker.hs:876:20: error:
    Not in scope: ‘Rank2.TH.unsafeDeriveApply’
    Perhaps you meant ‘Rank2.TH.deriveApply’ (imported from Rank2.TH)
    Module ‘Rank2.TH’ does not export ‘unsafeDeriveApply’.
    |
876 | $(mconcat <$> mapM Rank2.TH.unsafeDeriveApply
    |                    ^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-1774/language-oberon-0.2.1'
cabal: Error: some packages failed to install:
language-oberon-0.2.1-KfHXSSwkxOwYFLmRmZuF1 failed during the building phase.
The exception was:
ExitFailure 1