Metadata revisions for token-bucket-0.1.0.1

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User Changes
-r4 Sat Aug 11 20:01:56 UTC 2018 HerbertValerioRiedel
  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.12
    to
    >=4.6 && <4.13

  • Changed the test suite 'test-tb' component's library dependency on 'base' from

    >=4.6 && <4.12
    to
    >=4.6 && <4.13

-r3 Sun Mar 25 13:44:34 UTC 2018 HerbertValerioRiedel
  • Changed description from

    This implementation is heavily inspired by the one described in
    <http://ksdlck.com/post/17418037348/rate-limiting-at-webscale-lazy-leaky-buckets "Rate Limiting at Webscale: Lazy Leaky Buckets">
    to
    This package provides a variant of a [Token Bucket](https://en.wikipedia.org/wiki/Token_bucket)
    or [Leaky Bucket](https://en.wikipedia.org/wiki/Leaky_bucket) rate-limiting algorithm optimised for low overhead.
    
    The rate-limiting variant implemented by this package is heavily inspired by the algorithm described in
    <https://web.archive.org/web/20120808023806/http://ksdlck.com/post/17418037348/rate-limiting-at-webscale-lazy-leaky-buckets "Rate Limiting at Webscale: Lazy Leaky Buckets">.

  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.11
    to
    >=4.6 && <4.12

  • Changed the library component's library dependency on 'time' from

    >=1.4 && <1.7
    to
    >=1.4 && <1.9

  • Changed the test suite 'test-tb' component's library dependency on 'base' from

    >=4.6 && <4.10
    to
    >=4.6 && <4.12

  • Changed the test suite 'test-tb' component's library dependency on 'time' from

    >=1.4 && <1.7
    to
    >=1.4 && <1.9

-r2 Sat Apr 8 21:11:25 UTC 2017 HerbertValerioRiedel
  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.10
    to
    >=4.6 && <4.11

-r1 Mon Feb 8 14:14:40 UTC 2016 HerbertValerioRiedel
  • Changed the library component's library dependency on 'base' from

    >=4.6 && <4.9
    to
    >=4.6 && <4.10

  • Changed the library component's library dependency on 'time' from

    >=1.4 && <1.6
    to
    >=1.4 && <1.7

  • Changed the test suite 'test-tb' component's library dependency on 'base' from

    >=4.6 && <4.9
    to
    >=4.6 && <4.10

  • Changed the test suite 'test-tb' component's library dependency on 'time' from

    >=1.4 && <1.6
    to
    >=1.4 && <1.7

-r0 Sat Dec 6 09:02:34 UTC 2014 HerbertValerioRiedel