unix-compat: Portable POSIX-compatibility layer.

[ bsd3, library, system ] [ Propose Tags ]

This package provides portable implementations of parts of the unix package. This package re-exports the unix package when available. When it isn't available, portable implementations are used.

Versions [faq] 0.1, 0.1.1, 0.1.2.0, 0.1.2.1, 0.2, 0.2.1, 0.2.1.1, 0.2.1.2, 0.2.1.3, 0.2.2, 0.2.2.1, 0.3, 0.3.0.1, 0.3.0.2, 0.4.0.0, 0.4.1.0, 0.4.1.1, 0.4.1.3, 0.4.1.4, 0.4.2.0, 0.4.3.0, 0.4.3.1, 0.5, 0.5.0.1, 0.5.1, 0.5.2 (info)
Dependencies base (==4.*), directory (>=1.0 && <1.4), old-time (>=1.0.0.0 && <1.2.0.0), time (>=1.0 && <1.9), unix (>=2.4 && <2.9), Win32 (>=2.5.0.0) [details]
License BSD-3-Clause
Author Björn Bringert, Duncan Coutts, Jacob Stanley, Bryan O'Sullivan
Maintainer Jacob Stanley <jacob@stanley.io>
Revised Revision 1 made by JacobStanley at 2019-05-12T23:12:40Z
Category System
Home page http://github.com/jacobstanley/unix-compat
Source repo head: git clone git://github.com/jacobstanley/unix-compat.git
Uploaded by JacobStanley at 2018-08-23T00:46:03Z
Distributions Arch:0.5.2, Debian:0.5.1, Fedora:0.5.2, FreeBSD:0.4.1.4, LTSHaskell:0.5.1, NixOS:0.5.2, Stackage:0.5.1, openSUSE:0.5.2
Downloads 189011 total (1374 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2018-08-23 [all 1 reports]

Modules

[Index] [Quick Jump]

Flags

NameDescriptionDefaultType
old-time

build against old-time package

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees