The cabal-helper package

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

Warnings:

cabal-helper provides a library which wraps the internal use of an executable to lift the restrictions imposed by linking against versions of GHC before 7.10. This has the pleasant side effect of isolating the user from having to deal with Cabal version changes manually as cabal-helper can simply recompile it's helper program automatically as needed.

cabal-helper uses a wrapper executable to compile the actual cabal-helper executable at runtime while linking against an arbitrary version of Cabal. This runtime-compiled helper executable is then used to extract various bits and peices from Cabal's on disk state (dist/setup-config) written by it's configure command.

In addition to this the wrapper executable also supports installing any version of Cabal from hackage in case it cannot be found in any available package database. The wrapper installs these instances of the Cabal library into a private package database so as to not interfere with the user's packages.

Furthermore the wrapper supports one special case namely reading a state file for Cabal itself. This is needed as Cabal compiles it's Setup.hs using itself and not using any version of Cabal installed in any package database.

cabal-helper can compile with Cabal >= 1.14 but requires Cabal >= 1.16 at runtime.


[Skip to ReadMe]

Properties

Versions0.1.0.0, 0.1.0.1, 0.2.0.0, 0.3.0.0, 0.3.1.0, 0.3.2.0, 0.3.2.1, 0.3.3.0, 0.3.4.0, 0.3.5.0, 0.3.6.0, 0.3.7.0, 0.3.8.0, 0.3.9.0, 0.4.0.0, 0.5.0.0, 0.5.1.0, 0.5.2.0, 0.5.3.0, 0.6.0.0, 0.6.1.0, 0.6.2.0, 0.6.3.0, 0.6.3.1, 0.7.0.1, 0.7.1.0, 0.7.2.0, 0.7.3.0, 0.8.0.0
Change logNone available
Dependenciesbase (>=4.5 && <5), bytestring (>=0.9.2.1 && <0.11), Cabal (>=1.14 && <1.26 || ==2.0.*), containers, directory (>=1.1.0.2 && <1.4), filepath (>=1.3.0.0 && <1.5), ghc-prim, mtl (>=2.0 && <2.3), process (>=1.1.0.1 && <1.7), template-haskell, temporary (>=1.2.0.4 && <1.3), transformers (>=0.3.0.0 && <0.6), utf8-string (>=1.0.1.1 && <1.1) [details]
LicenseAGPL-3[multiple license files]
AuthorDaniel Gröber <dxld@darkboxed.org>
Maintainerdxld@darkboxed.org
CategoryDistribution
Source repositoryhead: git clone https://github.com/DanielG/cabal-helper.git
Executablescabal-helper-main, cabal-helper-wrapper
UploadedTue Sep 5 21:26:21 UTC 2017 by DanielG

Modules

Flags

NameDescriptionDefaultType
dev

Build development components

DisabledManual

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees


Readme for cabal-helper-0.8.0.0

[back to package description]

cabal-helper

cabal-helper provides a library which wraps the internal use of anexecutable to lift the restrictions imposed by linking against versions of GHC before 7.10. This has the pleasant side effect of isolating the user from having to deal with Cabal version changes manually as cabal-helper can simply recompile it's helper program automatically as needed.

cabal-helper uses a wrapper executable to compile the actual cabal-helper executable at runtime while linking against an arbitrary version of Cabal. This runtime-compiled helper executable is then used to extract various bits and peices from Cabal's on disk state (dist/setup-config) written by it's configure command.

In addition to this the wrapper executable also supports installing any version of Cabal from hackage in case it cannot be found in any available package database. The wrapper installs these instances of the Cabal library into a private package database so as to not interfere with the user's packages.

Furthermore the wrapper supports one special case namely reading a state file for Cabal itself. This is needed as Cabal compiles it's Setup.hs using itself and not using any version of Cabal installed in any package database.

cabal-helper can compile with Cabal >= 1.14 but requires Cabal >= 1.16 at runtime.

IRC

If you have any problems, suggestions, comments swing by #ghc-mod (web client) on Freenode. If you're reporting a bug please also create an issue here so we have a way to contact you if you don't have time to stay.

Do hang around for a while if no one answers and repeat your question if you still haven't gotten any answer after a day or so. You're most likely to get an answer during the day in GMT+1.