The cabalvchk package

[Tags: bsd3, program]

This utility can be used to verify the version of an installed package against version constraints. The version constraints can be specified in typical cabal fashion (e.g. >= 8.3, == 0.9.*, >= 8.3 && < 9.0).

Usage: cabalvchk package-name version-constraints [verbose]

Note that the version-constraints will probably need to be enclosed in single-quotes to prevent the shell from interpreting characters in the specification.

One use of this utility is by external configuration/validation utilities (e.g. autoconf) to verify installed package versions without running a cabal build. This utility produces no output (unless a third argument is specified) and the return value is 0 if the constraints are met or non-zero if the constraints are not met (including if the package is not installed).

Changes in 0.3:

Changes in 0.2:


Properties

Versions0.2, 0.3
Dependenciesbase (==4.*), Cabal (>1.10 && <2)
LicenseBSD3
AuthorKevin Quick
Maintainerquick@sparq.org
CategoryDistribution
Executablescabalvchk
Upload dateSat Jan 14 07:24:57 UTC 2012
Uploaded byKevinQuick
Downloads189 total (17 in last 30 days)

Downloads

Maintainers' corner

For package maintainers and hackage trustees