camfort: CamFort - Cambridge Fortran infrastructure

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain]

CamFort is a tool for the analysis, transformation, verification of Fortran code.

Properties

Versions0.62, 0.615, 0.700, 0.800, 0.802, 0.804, 0.900, 0.901, 0.902, 0.903, 0.904, 0.905, 0.906, 1.0, 1.0
Change logCHANGELOG.md
Dependenciesarray (>=0.4 && <0.6), base (>=4.6 && <5), binary (>=0.8.3.0 && <0.9), bytestring (==0.10.*), camfort, containers (>=0.5.0.0 && <0.7), deepseq, directory (>=1.2 && <1.4), fgl (>=5.6 && <5.8), filepath (==1.4.*), fortran-src (==0.4.*), GenericPretty (>=1.2.2 && <1.3), ghc-prim (>=0.3.1.0 && <0.6), hmatrix (==0.20.*), lattices (>=2.0.0 && <2.1), lens (>=4.15.1 && <5), matrix (>=0.2.2 && <0.4), mmorph (>=1.0.9 && <2), mtl (>=2.1 && <2.3), optparse-applicative (>=0.14 && <0.16), parallel, pipes, pretty (>=1.1 && <2), sbv (>=8.0 && <9), singletons (>=2.2 && <3), strict (>=0.3.2 && <1), syb (>=0.4 && <0.8), syz (==0.2.*), template-haskell (>=2.11 && <3), text (>=0.11.2.3 && <1.3), transformers (>=0.5.5.0 && <0.6), uniplate (>=1.6.10 && <1.7), vector (>=0.1 && <0.13), verifiable-expressions (>=0.6.0 && <0.7.0), vinyl (>=0.6 && <1.0) [details]
LicenseApache-2.0
Copyright2012-2019 University of Cambridge
AuthorMatthew Danish, Mistral Contrastin, Andrew Rice, Dominic Orchard
MaintainerMatthew Danish
CategoryLanguage
Home pagehttps://camfort.github.io
Bug trackerhttps://github.com/camfort/camfort/issues
Source repositoryhead: git clone https://github.com/camfort/camfort
Executablescamfort
UploadedThu Aug 29 14:54:52 UTC 2019 by mdanish

Modules

Downloads

Maintainers' corner

For package maintainers and hackage trustees