verifiable-expressions: An intermediate language for Hoare logic style verification.

[ apache, language, library ] [ Propose Tags ]

A typed intermediate language for Hoare logic style verification. It defines the intermediate language and combinators to interact it.

Versions [faq] 0.4.0, 0.5.0
Dependencies base (>=4.9 && <5), containers (>=0.5.7 && <0.7), lens (>=4.16.1 && <5), mtl (>=2.0 && <3), sbv (>=7.0 && <8), transformers (==0.5.*), union (>=0.1.1 && <0.2), vinyl (>=0.8.1 && <0.9) [details]
License Apache-2.0
Author Bradley Hardy
Maintainer madgenhetic@gmail.com
Category Language
Home page https://github.com/camfort/verifiable-expressions#readme
Bug tracker https://github.com/camfort/verifiable-expressions/issues
Source repo head: git clone https://github.com/camfort/verifiable-expressions
Uploaded by mdanish at Mon Jun 17 21:51:38 UTC 2019
Distributions NixOS:0.5.0
Downloads 267 total (25 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-06-17 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees