The edge package

[maintain]
Warnings:

The Edge has always been a rough patch of interstellar space filled with innumerable bad guys of every nefarious sort, and dangerous debris flying in every direction at high speeds. But now it has grown out of control and is threatening to overflow into colonial space. Central command has decided to send in their newest super weapon, the Mark II Lance fighter, piloted by their top ace pilot. Good luck commander!


[Skip to ReadMe]

Properties

Versions0.8, 0.8.2, 0.8.4, 0.8.6, 0.8.8, 0.8.10, 0.8.12, 0.8.12.1, 0.8.14, 0.8.16, 0.8.18, 0.8.20, 0.9.0.1, 0.9.0.2, 0.9.1.0, 0.9.1.1, 0.9.1.1
DependenciesALUT (==2.2.*), base (==4.*), cmdtheline (>=0.2.1.1 && <0.3), containers (>=0.4.2.1 && <0.6), gloss (>=1.7.4.1 && <1.9), OpenAL (==1.4.0.2), random (>=1.0.1.1 && <1.1), wraparound (>=0.0.2 && <0.1) [details]
LicenseGPL-3
AuthorChristopher Howard
Maintainerch.howard@zoho.com
CategoryGame
Home pagehttps://qlfiles.net/the-ql-files/the-edge/
Executablesedge
UploadedMon Sep 5 19:12:00 UTC 2016 by infrared

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for edge-0.9.1.1

README for edge package

There are, unfortunately, a number of complexities and difficulties in the dependency tree, which I think would make it difficult to compile on most platforms. However, it does build on the Debian Jessie release, with ghc-7.6.3 installed:

sudo apt-get install ghc cabal-install libghc-gloss-dev libghc-alut-dev
cabal update
cabal install edge
~/.cabal/bin/edge

If you have already have version of gloss, OpenAL, or GLUT Haskell libraries installed via cabal, you may wish to remove them first with ghc-pkg unregister gloss etc.