The graphics-drawingcombinators package

[Tags: bsd3, library]

This module is a functional wrapper around OpenGL, so you don't have to go into the deep, dark world of imperative stateful programming just to draw stuff. It supports 2D only (for now), with support drawing geometry, images, and text.


Properties

Versions0.1, 0.2, 0.3, 0.4, 0.41, 0.42, 0.43, 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.1.0, 1.1.1, 1.2.0, 1.2.1, 1.2.2, 1.3.0, 1.3.1, 1.4.0, 1.4.1, 1.4.2, 1.4.3, 1.4.4, 1.4.4.1, 1.5
Dependenciesbase (==4.*), bitmap-opengl (==0.0.*), containers, FTGL, OpenGL (==2.4.*), stb-image (==0.2.*) or
base (==4.*), bitmap-opengl (==0.0.*), containers, GLUT, OpenGL (==2.4.*), stb-image (==0.2.*)
LicenseBSD3
AuthorLuke Palmer
Maintainerlrpalmer@gmail.com
Stabilityexperimental
CategoryGraphics
Home pagehttp://github.com/luqui/graphics-drawingcombinators
Upload dateWed Mar 24 01:33:39 UTC 2010
Uploaded byLukePalmer
Downloads1830 total (132 in last 30 days)

Modules

[Index]

Flags

NameDescriptionDefault
ftglDoes the system have FTGL, thus we could use not sucky fontsEnabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees