hopenssl: FFI bindings to OpenSSL's EVP digest interface

[ bsd3, cryptography, foreign, library ] [ Propose Tags ]
Versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.6, 1.6.1, 1.6.2, 1.7, 2, 2.1, 2.2, 2.2.1
Dependencies base (>=3 && <5), bytestring, mtl [details]
License BSD-3-Clause
Copyright (c) 2004-2013 Peter Simons
Author Peter Simons <simons@cryp.to>, Jesper Louis Andersen <jesper.louis.andersen@gmail.com>, Markus Rothe <markus@unixforces.net>
Maintainer Peter Simons <simons@cryp.to>
Category Foreign, Cryptography
Home page http://github.com/peti/hopenssl
Source repo head: git clone git://github.com/peti/hopenssl.git
Uploaded by PeterSimons at Fri Apr 5 20:30:33 UTC 2013
Distributions LTSHaskell:2.2.1, NixOS:2.2.1, Stackage:2.2.1, openSUSE:2.2.1
Downloads 5225 total (74 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]
Hackage Matrix CI

Foreign-function bindings to the OpenSSL library http://www.openssl.org/. Currently provides access to the messages digests MD5, SHA, SHA1, DSS, DSS1, and RIPEMD160 through the EVP digest interface.




Maintainer's Corner

For package maintainers and hackage trustees