The hubris package

[Tags:library, program]

Support library for Hubris, the Ruby to Haskell bridge more info at

short version: ./Setup configure --enable-shared --ghc-options=-dynamic --extra-include-dirs=... --extra-lib-dirs=...

If you omit any of those flags, it will seem to work then blow up at runtime.

Anyway, this version strips the boilerplate that used to be necessary, and is intended to be used in conjunction with


Versions 0.0.1, 0.0.2, 0.0.3
Dependencies array, base (>=3 && <5), bytestring, Cabal (>=1.7.4 && <1.9), containers, ghc, ghc-paths, haskell98, hint, mtl, old-time, process [details]
License OtherLicense
Author Mark Wotton <>
Maintainer Mark Wotton <>
Stability Experimental
Category Language
Bug tracker
Uploaded Sun Nov 29 13:25:42 UTC 2009 by MarkWotton
Distributions NixOS:0.0.3
Downloads 600 total (3 in the last 30 days)
0 []
Status Docs not available [build log]
All reported builds failed as of 2015-11-21 [all 4 reports]


  • Includes
  • Language
    • Ruby
      • Language.Ruby.Hubris
        • Language.Ruby.Hubris.Binding
        • Language.Ruby.Hubris.GHCBuild
        • Language.Ruby.Hubris.LibraryBuilder
        • Language.Ruby.Hubris.ZCode


Maintainer's Corner

For package maintainers and hackage trustees