The lub package

[Tags: bsd3, library]

Lub is an experiment in computing least upper information bounds on (partially defined) functional values. It provides a lub function that is consistent with the unamb operator but has a more liberal precondition. Where unamb requires its arguments to equal when neither is bottom, lub is able to synthesize a value from the partial information contained in both of its arguments.

This module also defines glb, which intersects information.

Project wiki page:

© 2008 by Conal Elliott; BSD3 license.

[Skip to ReadMe]


Versions0.0.0, 0.0.1, 0.0.2, 0.0.3, 0.0.4, 0.0.5, 0.0.6, 0.1.1, 0.1.2, 0.1.3, 0.1.5, 0.1.6, 0.1.7
Change logNone available
Dependenciesbase (<5), unamb (>=0.2.4) [details]
Copyright(c) 2008,2009,2010 by Conal Elliott
AuthorConal Elliott
CategoryConcurrency, Data, Other
Home page
UploadedFri Sep 24 16:43:28 UTC 2010 by ConalElliott
Downloads2025 total (89 in last 30 days)
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]




Maintainers' corner

For package maintainers and hackage trustees

Readme for lub-0.1.5

See for a description of the lub package.

You can configure, build, and install all in the usual way with Cabal

  runhaskell Setup.lhs configure
  runhaskell Setup.lhs build
  runhaskell Setup.lhs install