The milena package

[Tags:bsd3, library, test]

A Kafka client for Haskell. The protocol module is stable (the only changes will be to support changes in the Kafka protocol). The API is functional but subject to change.


[Skip to Readme]

Properties

Versions 0.1.0.0, 0.2.0.0, 0.3.0.0, 0.4.0.0, 0.4.0.1, 0.5.0.0, 0.5.0.1, 0.5.0.2
Dependencies base (>=4.7 && <5), bytestring (==0.10.*), cereal (>=0.4 && <0.6), containers (==0.5.*), digest (>=0.0.1.0 && <0.1), lens (>=4.4 && <4.16), lifted-base (>=0.2.3.6 && <0.3), mtl (>=2.1 && <2.3), murmur-hash (>=0.1.0.8 && <0.2), network (>=2.4 && <2.7), random (>=1.0 && <1.2), resource-pool (>=0.2.3.2 && <0.3), semigroups (>=0.16.2.2 && <0.19), transformers (>=0.3 && <0.6) [details]
License BSD3
Copyright 2014, Tyler Holien
Author Tyler Holien
Maintainer adam@adamflott.com
Category Network
Bug tracker https://github.com/adamflott/milena/issues
Source repository head: git clone https://github.com/adamflott/milena.git
this: git clone https://github.com/adamflott/milena.git(tag 0.5.0.2)
Uploaded Tue Feb 7 16:34:16 UTC 2017 by adamflott
Distributions NixOS:0.5.0.2
Downloads 797 total (6 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2017-02-07 [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Readme for milena

Readme for milena-0.5.0.2

Milena

A Kafka client for Haskell.

Supports Kafka 0.8.x and up (including 0.9.x).

The protocol module is stable (the only changes will be to support changes in the Kafka protocol). The API is functional but subject to change.

Limitations

Some of the known limitations.

  • Does not yet support compression
  • Does not yet support consumer groups