The prelude-compat package

[Tags:bsd3, library]

This package allows you to write warning-free code that compiles with versions of base before and after AMP and FTP, that is, base before and beginning with 4.8, respectively, and GHC before and beginning with 7.10, respectively. It serves three purposes:

You should add

 import Prelude2010
 import Prelude ()

to your modules. This way, you must change all affected modules. If you want to avoid this you may try the prelude2010 package or if you already import Prelude explicitly, you may try to add

 Default-Extensions: CPP, NoImplicitPrelude
 CPP-Options: -DPrelude=Prelude2010

to your Cabal file.

In my opinion, this is the wrong way round. The presented Prelude2010 module should have been the one for GHC-7.10 and the Prelude with added and generalized list functions should have been an additionally PreludeFTP, preferably exported by a separate package like all other alternate Prelude projects. But the purpose of the FTP was to save some import statements at the expense of blowing up the Foldable class and prevent simple ways to write code that works with GHC version before and starting with GHC-7.10 and that does not provoke warnings.

Related packages:

Properties

Versions 0.0, 0.0.0.1 (info)
Dependencies base (>=3 && <5) [details]
License BSD3
Author Henning Thielemann
Maintainer haskell@henning-thielemann.de
Category Prelude, Haskell2010
Source repository this: darcs get http://hub.darcs.net/thielema/prelude-compat --tag 0.0.0.1
head: darcs get http://hub.darcs.net/thielema/prelude-compat
Uploaded Sat Apr 16 18:26:14 UTC 2016 by HenningThielemann
Distributions LTSHaskell:0.0.0.1, NixOS:0.0.0.1, Stackage:0.0.0.1, Tumbleweed:0.0.0.1
Downloads 95 total (9 in the last 30 days)
Votes
0 []
Status Docs available [build log]
Last success reported on 2016-04-16 [all 1 reports]

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees