servant-auth-wordpress: Authenticate Routes Using Wordpress Cookies

[ bsd3, library, servant, web ] [ Propose Tags ]

This package provides a Servant AuthHandler that validates Wordpress's LOGGED_IN authentication Cookie & the wp_rest Nonce, returning either an Authorized user with data or an Anonymous user, or calling an error handler.

This allows you to access the currently logged in User when making AJAX requests from a Wordpress site.

Check out the wordpress-auth package for lower-level Wordpress Cookie & Nonce manipulation.


[Skip to Readme]
Versions [faq] 1.0.0.0, 1.0.0.1
Change log CHANGELOG.md
Dependencies base (>=4.7 && <5), mtl (==2.*), servant-server (>=0.14 && <0.17), text (==1.*), time (==1.*), wai (==3.*), wordpress-auth (>=1 && <1.1) [details]
License BSD-3-Clause
Copyright BSD3
Author Pavan Rikhi
Maintainer pavan.rikhi@gmail.com
Category Web, Servant
Home page https://github.com/prikhi/wordpress-auth#readme
Uploaded by lysergia at Fri Mar 1 19:20:21 UTC 2019
Distributions NixOS:1.0.0.1, Stackage:1.0.0.1
Downloads 231 total (21 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2019-03-01 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees


Readme for servant-auth-wordpress-1.0.0.1

[back to package description]

servant-auth-wordpress

This package provides a Servant AuthHandler that validates Wordpress's @LOGGED_IN@ authentication Cookie & the @wp_rest@ Nonce, returning either an Authorized user with data or an Anonymous user, or calling an error handler.

This allows you to access the currently logged in User when making AJAX requests from a Wordpress site.

Check out the @wordpress-auth@ package for lower-level Wordpress Cookie & Nonce manipulation.

License

BSD 3-clause, exceptions possible.