The tamarin-prover package

[ Tags: deprecated, gpl, program, theorem-provers ] [ Propose Tags ]
Deprecated.

The Tamarin prover is a tool for the analysis of security protocols. It implements a constraint solving algorithm that supports both falsification and verification of security protocols with respect to an unbounded number of sessions. The underlying security protocol model uses multiset rewriting to specify protocols and adversary capabilities, a guarded fragment of first-order logic to specify security properties, and equational theories to model the algebraic properties of cryptographic operators.

The paper describing the theory underlying the Tamarin prover was accepted at CSF 2012. Its extended version is available from http://www.infsec.ethz.ch/research/software/tamarin.

The Tamarin prover supports both a batch analysis mode and the interactive construction of security proofs using a GUI. Example protocols and the user guide are installed together with the prover. Just call the tamarin-prover executable without any arguments to get more information.

The Tamarin prover uses maude (http://maude.cs.uiuc.edu/) as a unification backend and GraphViz (http://www.graphviz.org/) to visualize constraint systems. Detailed instructions for installing the Tamarin prover are given at http://www.infsec.ethz.ch/research/software/tamarin.

Properties

Versions 0.1.0.0, 0.1.1.0, 0.4.0.0, 0.4.1.0, 0.6.0.0, 0.6.1.0, 0.8.0.0, 0.8.1.0, 0.8.2.0, 0.8.2.1, 0.8.4.0, 0.8.5.0, 0.8.5.1, 0.8.6.0, 0.8.6.1, 0.8.6.2, 0.8.6.3
Dependencies aeson (==0.6.*), array (>=0.3 && <0.5), base (==4.*), binary (==0.5.*), blaze-builder (==0.3.*), blaze-html (==0.4.*), bytestring (==0.9.*), cmdargs (==0.9.*), containers (>=0.4.2 && <0.5), deepseq (==1.3.*), derive (==2.5.*), directory (>=1.0 && <1.2), dlist (==0.5.*), fast-logger (==0.0.2), fclabels (==1.1.*), filepath (>=1.1 && <1.4), hamlet (==1.0.*), http-types (==0.6.*), HUnit (==1.2.*), lifted-base (==0.1.*), monad-control (==0.3.*), mtl (==2.0.*), old-locale (==1.0.*), parallel (==3.2.*), parsec (==3.1.*), process (==1.1.*), safe (>=0.2 && <0.4), syb (>=0.3.3 && <0.4), tamarin-prover-term (>=0.8.1 && <0.9), tamarin-prover-utils (>=0.8.1 && <0.9), text (==0.11.*), threads (>=0.4 && <0.6), time (>=1.2 && <1.5), transformers (==0.2.*), uniplate (==1.6.*), wai (==1.2.*), wai-logger (==0.1.*), warp (==1.2.*), yesod-core (==1.0.*), yesod-json (==1.0.*), yesod-static (==1.0.*) [details]
License GPL
Copyright Benedikt Schmidt, Simon Meier, ETH Zurich, 2010-2012
Author Benedikt Schmidt <benedikt.schmidt@inf.ethz.ch>, Simon Meier <simon.meier@inf.ethz.ch>
Maintainer Simon Meier <simon.meier@inf.ethz.ch>
Category Theorem Provers
Home page http://www.infsec.ethz.ch/research/software/tamarin
Source repository head: git clone https://github.com/tamarin-prover/tamarin-prover.git
Uploaded Mon Aug 13 21:39:04 UTC 2012 by SimonMeier
Distributions Arch:1.2.2, NixOS:0.8.6.3
Executables tamarin-prover
Downloads 3240 total (21 in the last 30 days)
Rating 0.0 (0 ratings) [clear rating]
  • λ
  • λ
  • λ
Status Docs not available [build log]
All reported builds failed as of 2016-12-24 [all 6 reports]
Hackage Matrix CI

Flags

NameDescriptionDefaultType
no-gui

Do not build the web-application GUI.

DisabledAutomatic
threaded

Build with support for multithreaded execution

EnabledAutomatic
test-coverage

Build with test coverage support

EnabledAutomatic
build-tests

Build unit test driver

DisabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees