unbeliever: Opinionated Haskell Interoperability

[ bsd3, library, system ] [ Propose Tags ]

A library to help build command-line programs, both tools and longer-running daemons.

A description of this package, a list of features, and some background to its design is contained in the README on GitHub.

An ancillary aim of this library is to facilitate interoperability. A single batteries-included package would make this easier, but the resulting dependency footprint would be considerable. The code is thus spread across several packages:

Useful starting points in the documentation are Core.Program.Execute and Core.Text.Rope.

Versions [faq] 0.7.3.0, 0.8.0.0, 0.9.2.0, 0.9.3.2, 0.10.0.0, 0.10.0.1 (info)
Dependencies None [details]
License BSD-3-Clause
Copyright © 2018-2019 Operational Dynamics Consulting Pty Ltd, and Others
Author Andrew Cowie <andrew@operationaldynamics.com>
Maintainer Andrew Cowie <andrew@operationaldynamics.com>
Revised Revision 2 made by AndrewCowie at Fri Jul 12 13:03:57 UTC 2019
Category System
Home page https://github.com/oprdyn/unbeliever#readme
Bug tracker https://github.com/oprdyn/unbeliever/issues
Source repo head: git clone https://github.com/oprdyn/unbeliever
Uploaded by AndrewCowie at Fri Jul 12 12:57:55 UTC 2019
Distributions NixOS:0.9.3.2, Stackage:0.9.3.2
Downloads 406 total (125 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs not available [build log]
All reported builds failed as of 2019-07-12 [all 3 reports]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees