The uuagc package

[Tags: bsd3, library, program]

Generates Haskell files from an attribute grammar specification


[Skip to ReadMe]

Properties

Versions0.9.5, 0.9.6, 0.9.7, 0.9.10, 0.9.11, 0.9.12, 0.9.13, 0.9.14, 0.9.15, 0.9.16, 0.9.17, 0.9.18, 0.9.19, 0.9.20, 0.9.21, 0.9.23, 0.9.24, 0.9.26, 0.9.27, 0.9.28, 0.9.29, 0.9.30, 0.9.31, 0.9.32, 0.9.33, 0.9.34, 0.9.35, 0.9.36, 0.9.37.0, 0.9.37.1, 0.9.37.2, 0.9.38.0, 0.9.38.1, 0.9.38.3, 0.9.38.4, 0.9.38.5, 0.9.38.6, 0.9.39.0, 0.9.39.1, 0.9.39.3, 0.9.40.1, 0.9.40.2, 0.9.40.3, 0.9.42.0, 0.9.42.1, 0.9.42.2, 0.9.42.3, 0.9.50, 0.9.50.1, 0.9.50.2, 0.9.51, 0.9.52, 0.9.52.1
Change logNone available
Dependenciesarray, base (==4.*), Cabal, containers, directory, filepath, ghc-prim, haskell98, process, uulib (>=0.9.12) [details]
LicenseGPL
CopyrightUniversiteit Utrecht
MaintainerArie Middelkoop <ariem@cs.uu.nl>
StabilityStable
CategoryDevelopment
Home pagehttp://www.cs.uu.nl/wiki/HUT/WebHome
Executablesuuagc
UploadedWed Jul 14 08:10:43 UTC 2010 by ArieMiddelkoop
DistributionsDebian:0.9.42.3, FreeBSD:0.9.52.1, NixOS:0.9.52.1
Downloads10422 total (379 in last 30 days)
Votes
0 []
StatusDocs uploaded by user
Build status unknown [no reports yet]

Modules

[Index]

Flags

NameDescriptionDefaultType
compatibility1compatibility flag.EnabledAutomatic
compatibility2compatibility flag.EnabledAutomatic

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees

Readme for uuagc-0.9.29

Please pick the right section in this file for instructions depending on how you optained the uuagc sources.

IMPORTANT: We assume that you have the latest official release of GHC installed together with the accompanying Cabal package. For older GHC installations, rename:
   uuagc.cabal-for-ghc-6.6      to    uuagc.cabal
 or upgrade to at least Cabal-1.2.x


-------------------------------------------
Installing uuagc from a source distribution
-------------------------------------------
Here we assume that you have downloaded the sources from http://www.cs.uu.nl/wiki/HUT/Download .

    ghc --make Setup.hs -o setup -package Cabal
    ./setup configure
    ./setup build
    ./setup install

  The 1.0 release of Cabal has a bug that prevents
  the installation step from succeeding.
  You may prefer to use the following alternative:

    ./configure
    make build
    make install

-------------------------------
Using the user package database
-------------------------------

  In the case that you registered uulib in your
  user package database you may install uuagc
  thusly:

    ghc --make Setup.hs -o setup -package Cabal
    ./setup configure --user
    ./setup build
    ./setup install

  Or, alternatively:

    ./configure --with-user-pckg
    make build
    make install

---------------------------------------------------------------
Installing uuagc after checking out from the svn respository
---------------------------------------------------------------
Please note that this is only possible if you alreday have a running version of the uuagc on your system. 
This can be downloaded from: http://www.cs.uu.nl/wiki/HUT/Download

  First execute the steps below:

    autoconf
    ./configure
    make build
    make install