Build #7 for yi-0.4.1

[all reports]

Package yi-0.4.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-03 13:35:42.70498 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies
Flags -vty testing pango -gtk -ghcapi -cocoa

Build log

[view raw]

Resolving dependencies...
Configuring yi-0.4.1...
Building yi-0.4.1...
Failed to install yi-0.4.1
Build log ( /home/builder/.cabal/logs/yi-0.4.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-20203/yi-0.4.1'
Configuring yi-0.4.1...
Building yi-0.4.1...
Preprocessing library yi-0.4.1...

Yi/Lexer/Alex.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

dist/build/Yi/Lexer/Compilation.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

Yi/Syntax/Layout.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

Yi/Syntax/Fractal.hs:1:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

Yi/Interpreter.hs:2:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead

Yi/Core.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead

Yi/Eval.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead

Yi/History.hs:1:14: warning:
    -XPatternSignatures is deprecated: use -XScopedTypeVariables or pragma {-# LANGUAGE ScopedTypeVariables #-} instead

Yi/IncrementalParse.hs:2:12: warning:
    -fglasgow-exts is deprecated: Use individual extensions instead
[ 1 of 88] Compiling Yi.UI.Common[boot] ( Yi/UI/Common.hs-boot, dist/build/Yi/UI/Common.o-boot )

Yi/UI/Common.hs-boot:1:8: error:
    Failed to load interface for ‘Prelude’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-20203/yi-0.4.1'
cabal: Error: some packages failed to install:
yi-0.4.1 failed during the building phase. The exception was:
ExitFailure 1