The yi package

[Tags: gpl, library, program]

Yi is a text editor written in Haskell and extensible in Haskell. The goal of the Yi project is to provide a flexible, powerful, and correct editor for haskell hacking.


Properties

Versions0.2, 0.3, 0.4, 0.4.1, 0.4.3, 0.4.6, 0.4.6.2, 0.5.0.1, 0.5.2, 0.6.0, 0.6.1, 0.6.2.2, 0.6.2.3, 0.6.2.4, 0.6.3.0, 0.6.4.0, 0.6.5.0, 0.6.6.0, 0.6.7.0, 0.7.0, 0.7.1, 0.7.2, 0.8.0, 0.8.1
Dependenciesarray, base, bytestring (>=0.9.0.1 && <0.9.2), Cabal (==1.4.*), containers, directory, filepath (>=1.0), fingertree, mtl, old-locale, old-time, parsec (==2.1.*), process, pureMD5 (>=0.2.3), random, regex-base (==0.93.1), regex-tdfa (==0.94), utf8-string (>=0.3.1)
LicenseGPL
AuthorAUTHORS
Maintaineryi-devel@googlegroups.com
CategoryEditor
Home pagehttp://haskell.org/haskellwiki/Yi
Executablesyi
Upload dateFri Jul 25 14:17:25 UTC 2008
Uploaded byJeanPhilippeBernardy
DistributionsDebian:0.7.1, NixOS:0.8.1
Downloads2591 total (437 in last 30 days)

Modules

Flags

NameDescriptionDefault
ghcapiEnable linking with GHC API for advanced features.Disabled
vtyProvide Vty UIEnabled
gtkProvide GTK UIEnabled
pangoProvide Pango UIEnabled
cocoaProvide experimental Cocoa UIEnabled
testingbake-in the self-checksEnabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainers' corner

For package maintainers and hackage trustees