Build #7 for Folly-0.1.1.0

[all reports]

Package Folly-0.1.1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-13 21:39:17.965354 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, containers-0.5.7.1, base-4.9.0.0, containers-0.5.7.1, parsec-3.1.11, HUnit-1.5.0.0, base-4.9.0.0, containers-0.5.7.1, parsec-3.1.11
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring call-stack-0.1.0...
Configuring mtl-2.2.1...
Building call-stack-0.1.0...
Building mtl-2.2.1...
Configuring text-1.2.2.1...
Installed call-stack-0.1.0
Building text-1.2.2.1...
Configuring HUnit-1.5.0.0...
Installed mtl-2.2.1
Building HUnit-1.5.0.0...
Installed HUnit-1.5.0.0
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring Folly-0.1.1.0...
Building Folly-0.1.1.0...
Failed to install Folly-0.1.1.0
Build log ( /home/builder/.cabal/logs/Folly-0.1.1.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-8683/Folly-0.1.1.0'
Configuring Folly-0.1.1.0...
Building Folly-0.1.1.0...
Preprocessing library Folly-0.1.1.0...
[1 of 4] Compiling Folly.Utils      ( src/Folly/Utils.hs, dist/build/Folly/Utils.o )

src/Folly/Utils.hs:12:10: error:
    • No instance for (Applicative Error)
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad Error’
cabal: Leaving directory '/tmp/cabal-tmp-8683/Folly-0.1.1.0'
cabal: Error: some packages failed to install:
Folly-0.1.1.0 failed during the building phase. The exception was:
ExitFailure 1