Build #6 for Folly-0.1.4.4

[all reports]

Package Folly-0.1.4.4
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-01 16:16:22.03302 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, containers-0.5.7.1, parsec-3.1.11, base-4.9.0.0, containers-0.5.7.1, parsec-3.1.11, HUnit-1.5.0.0, base-4.9.0.0, containers-0.5.7.1, parsec-3.1.11
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring call-stack-0.1.0...
Configuring mtl-2.2.1...
Building call-stack-0.1.0...
Building mtl-2.2.1...
Installed call-stack-0.1.0
Configuring text-1.2.2.1...
Building text-1.2.2.1...
Configuring HUnit-1.5.0.0...
Installed mtl-2.2.1
Building HUnit-1.5.0.0...
Installed HUnit-1.5.0.0
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed parsec-3.1.11
Configuring Folly-0.1.4.4...
Building Folly-0.1.4.4...
Failed to install Folly-0.1.4.4
Build log ( /home/builder/.cabal/logs/Folly-0.1.4.4.log ):
cabal: Entering directory '/tmp/cabal-tmp-20093/Folly-0.1.4.4'
Configuring Folly-0.1.4.4...
Building Folly-0.1.4.4...
Preprocessing library Folly-0.1.4.4...
[1 of 7] Compiling Folly.Utils      ( src/Folly/Utils.hs, dist/build/Folly/Utils.o )
[2 of 7] Compiling Folly.Lexer      ( src/Folly/Lexer.hs, dist/build/Folly/Lexer.o )
[3 of 7] Compiling Folly.Formula    ( src/Folly/Formula.hs, dist/build/Folly/Formula.o )
[4 of 7] Compiling Folly.Theorem    ( src/Folly/Theorem.hs, dist/build/Folly/Theorem.o )
[5 of 7] Compiling Folly.Parser     ( src/Folly/Parser.hs, dist/build/Folly/Parser.o )
[6 of 7] Compiling Folly.Unification ( src/Folly/Unification.hs, dist/build/Folly/Unification.o )
[7 of 7] Compiling Folly.Resolution ( src/Folly/Resolution.hs, dist/build/Folly/Resolution.o )
Preprocessing executable 'Folly' for Folly-0.1.4.4...
[1 of 8] Compiling Folly.Utils      ( src/Folly/Utils.hs, dist/build/Folly/Folly-tmp/Folly/Utils.o )
[2 of 8] Compiling Folly.Lexer      ( src/Folly/Lexer.hs, dist/build/Folly/Folly-tmp/Folly/Lexer.o )
[3 of 8] Compiling Folly.Formula    ( src/Folly/Formula.hs, dist/build/Folly/Folly-tmp/Folly/Formula.o )
[4 of 8] Compiling Folly.Theorem    ( src/Folly/Theorem.hs, dist/build/Folly/Folly-tmp/Folly/Theorem.o )
[5 of 8] Compiling Folly.Parser     ( src/Folly/Parser.hs, dist/build/Folly/Folly-tmp/Folly/Parser.o )
[6 of 8] Compiling Folly.Unification ( src/Folly/Unification.hs, dist/build/Folly/Folly-tmp/Folly/Unification.o )
[7 of 8] Compiling Folly.Resolution ( src/Folly/Resolution.hs, dist/build/Folly/Folly-tmp/Folly/Resolution.o )
[8 of 8] Compiling Main             ( src/Main.hs, dist/build/Folly/Folly-tmp/Main.o )
Linking dist/build/Folly/Folly ...
Preprocessing executable 'Folly-tests' for Folly-0.1.4.4...
[ 1 of 13] Compiling Folly.Utils      ( src/Folly/Utils.hs, dist/build/Folly-tests/Folly-tests-tmp/Folly/Utils.o )
[ 2 of 13] Compiling Folly.Lexer      ( src/Folly/Lexer.hs, dist/build/Folly-tests/Folly-tests-tmp/Folly/Lexer.o )
[ 3 of 13] Compiling Folly.LexerTests ( test/Folly/LexerTests.hs, dist/build/Folly-tests/Folly-tests-tmp/Folly/LexerTests.o )

test/Folly/LexerTests.hs:4:1: error:
    Failed to load interface for ‘Folly.TestUtils’
    Perhaps you meant
      Folly.Utils (needs flag -package-key Folly-0.1.4.4)
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-20093/Folly-0.1.4.4'
cabal: Error: some packages failed to install:
Folly-0.1.4.4 failed during the building phase. The exception was:
ExitFailure 1