Build #16 for HMM-0.2.1

[all reports]

Package HMM-0.2.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-10-25 15:02:55.141319 UTC
Compiler ghc-8.0.1.20160701
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Entering directory '/tmp/cabal-tmp-7873/HMM-0.2.1'
Configuring HMM-0.2.1...
Building HMM-0.2.1...
Preprocessing library HMM-0.2.1...
[1 of 1] Compiling Data.HMM         ( Data/HMM.hs, dist/build/Data/HMM.o )

Data/HMM.hs:4:8: error:
    Failed to load interface for ‘Prelude’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

Data/HMM.hs:17:1: error:
    Failed to load interface for ‘Debug.Trace’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

Data/HMM.hs:18:1: error:
    Failed to load interface for ‘Data.Array’
    It is a member of the hidden package ‘array-0.5.1.1’.
    Perhaps you need to add ‘array’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

Data/HMM.hs:19:1: error:
    Failed to load interface for ‘Data.List’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

Data/HMM.hs:20:1: error:
    Failed to load interface for ‘Data.List.Extras’
    Use -v to see a list of the files searched for.

Data/HMM.hs:21:1: error:
    Failed to load interface for ‘Data.Number.LogFloat’
    Use -v to see a list of the files searched for.

Data/HMM.hs:22:1: error:
    Failed to load interface for ‘Data.MemoCombinators’
    Use -v to see a list of the files searched for.

Data/HMM.hs:23:1: error:
    Failed to load interface for ‘Control.Parallel’
    Use -v to see a list of the files searched for.

Data/HMM.hs:24:1: error:
    Failed to load interface for ‘System.IO’
    It is a member of the hidden package ‘base-4.9.0.0’.
    Perhaps you need to add ‘base’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

Data/HMM.hs:25:1: error:
    Failed to load interface for ‘Text.ParserCombinators.Parsec’
    Perhaps you meant
      Text.ParserCombinators.ReadPrec (needs flag -package-key base-4.9.0.0)
      Text.ParserCombinators.ReadP (needs flag -package-key base-4.9.0.0)
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-7873/HMM-0.2.1'
Failed to install HMM-0.2.1
cabal: Error: some packages failed to install:
HMM-0.2.1 failed during the building phase. The exception was:
ExitFailure 1