Build #9 for HsPerl5-0.0.6.20150815

[all reports]

Package HsPerl5-0.0.6.20150815
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-10-25 17:28:40.042896 UTC
Compiler ghc-8.0.1.20160701
OS linux
Arch x86_64
Dependencies base-4.9.0.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
cabal: Entering directory '/tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815/dist/setup/setup.hs, /tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815/dist/setup/Main.o )

/tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815/dist/setup/setup.hs:3:3: warning: [-Wdeprecations]
    Module ‘System.Cmd’ is deprecated: Use "System.Process" instead

/tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815/dist/setup/setup.hs:6:49: warning: [-Wdeprecations]
    In the use of ‘defaultUserHooks’
    (imported from Distribution.Simple):
    Deprecated: "Use simpleUserHooks or autoconfUserHooks, unless you need Cabal-1.2
             compatibility in which case you must stick with defaultUserHooks"
Linking /tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815/dist/setup/setup ...
Warning: defaultUserHooks in Setup script is deprecated.
Configuring HsPerl5-0.0.6.20150815...
Building HsPerl5-0.0.6.20150815...
Preprocessing library HsPerl5-0.0.6.20150815...

on the commandline: warning:
    -XOverlappingInstances is deprecated: instead use per-instance pragmas OVERLAPPING/OVERLAPPABLE/OVERLAPS
[1 of 1] Compiling Language.Perl5   ( src/Language/Perl5.hs, dist/build/Language/Perl5.o )
/usr/bin/ld: cannot find -lperl
collect2: error: ld returned 1 exit status
`gcc' failed in phase `Linker'. (Exit code: 1)
cabal: Leaving directory '/tmp/cabal-tmp-19798/HsPerl5-0.0.6.20150815'
Failed to install HsPerl5-0.0.6.20150815
cabal: Error: some packages failed to install:
HsPerl5-0.0.6.20150815 failed during the building phase. The exception was:
ExitFailure 1