Build #8 for NXT-0.1.6

[all reports]

Package NXT-0.1.6
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-28 19:01:28.027248 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, bytestring-0.10.8.1, mtl-2.2.1, time-1.6.0.1, unix-2.7.2.0, base-4.9.0.0, mtl-2.2.1, base-4.9.0.0, bytestring-0.10.8.1, filepath-1.4.1.0, mtl-2.2.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Installed mtl-2.2.1
Configuring NXT-0.1.6...
Building NXT-0.1.6...
Failed to install NXT-0.1.6
Build log ( /home/builder/.cabal/logs/NXT-0.1.6.log ):
cabal: Entering directory '/tmp/cabal-tmp-23546/NXT-0.1.6'
Configuring NXT-0.1.6...
Building NXT-0.1.6...
Preprocessing library NXT-0.1.6...
[ 1 of 12] Compiling Robotics.NXT.Externals ( lib/Robotics/NXT/Externals.hs, dist/build/Robotics/NXT/Externals.o )
[ 2 of 12] Compiling Robotics.NXT.Internals ( lib/Robotics/NXT/Internals.hs, dist/build/Robotics/NXT/Internals.o )

lib/Robotics/NXT/Internals.hs:15:58: error:
    • No instance for (Applicative NXT)
        arising from the 'deriving' clause of a data type declaration
      Possible fix:
        use a standalone 'deriving instance' declaration,
          so you can specify the instance context yourself
    • When deriving the instance for (Monad NXT)
cabal: Leaving directory '/tmp/cabal-tmp-23546/NXT-0.1.6'
cabal: Error: some packages failed to install:
NXT-0.1.6 failed during the building phase. The exception was:
ExitFailure 1