Build #3 for SciFlow-0.7.0

[all reports]

Package SciFlow-0.7.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-05-26 21:42:42.462323209 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: SciFlow-0.7.0 (user goal)
[__1] trying: stm-2.5.0.0/installed-2.5... (dependency of SciFlow)
[__2] next goal: distributed-process (dependency of SciFlow)
[__2] rejecting: distributed-process-0.7.4, distributed-process-0.7.3,
distributed-process-0.7.2 (conflict: stm==2.5.0.0/installed-2.5...,
distributed-process => stm>=2.4 && <2.5)
[__2] rejecting: distributed-process-0.7.1 (conflict: stm =>
base==4.12.0.0/installed-4.1..., distributed-process => base>=4.6 && <4.10)
[__2] rejecting: distributed-process-0.7.0 (conflict:
stm==2.5.0.0/installed-2.5..., distributed-process => stm>=2.4 && <2.5)
[__2] rejecting: distributed-process-0.6.6, distributed-process-0.6.5,
distributed-process-0.6.4, distributed-process-0.6.2,
distributed-process-0.6.1, distributed-process-0.6.0,
distributed-process-0.5.5.1, distributed-process-0.5.5,
distributed-process-0.5.4, distributed-process-0.5.3,
distributed-process-0.5.2, distributed-process-0.5.1,
distributed-process-0.5.0, distributed-process-0.4.2,
distributed-process-0.4.1, distributed-process-0.4.0.2,
distributed-process-0.4.0.1, distributed-process-0.4.0,
distributed-process-0.3.1, distributed-process-0.3.0,
distributed-process-0.2.3.0, distributed-process-0.2.2.0,
distributed-process-0.2.1.4, distributed-process-0.2.1.3,
distributed-process-0.2.1.2, distributed-process-0.2.1.1,
distributed-process-0.2.1, distributed-process-0.2.0.1,
distributed-process-0.2.0, distributed-process-0.6.3 (conflict: SciFlow =>
distributed-process==0.7.*)
[__2] fail (backjumping, conflict set: SciFlow, distributed-process, stm)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: distributed-process, SciFlow, base,
stm