Build #2 for alsa-gui-0.1.0.1

[all reports]

Package alsa-gui-0.1.0.1
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-08-09 12:15:07.152419218 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: alsa-gui-0.1.0.1 (user goal)
[__1] trying: wxcore-0.92.3.0 (dependency of alsa-gui)
[__2] trying: wxdirect-0.92.3.0 (dependency of wxcore)
[__3] next goal: process (dependency of wxdirect)
[__3] rejecting: process-1.6.3.0/installed-1.6..., process-1.6.5.1,
process-1.6.5.0, process-1.6.4.0, process-1.6.3.0, process-1.6.2.0,
process-1.6.1.0, process-1.6.0.0, process-1.5.0.0 (conflict: wxdirect =>
process>=1.1 && <1.5)
[__3] trying: process-1.4.3.0
[__4] next goal: directory (dependency of wxcore)
[__4] rejecting: directory-1.3.3.0/installed-1.3... (conflict: process =>
base>=4.4 && <4.11, directory => base==4.12.0.0/installed-4.1...)
[__4] trying: directory-1.3.4.0
[__5] next goal: containers (dependency of wxcore +/-splitbase)
[__5] rejecting: containers-0.6.0.1/installed-0.6..., containers-0.6.2.1,
containers-0.6.1.1, containers-0.6.0.1 (conflict: wxcore +/-splitbase =>
containers>=0.1 && <0.6)
[__5] trying: containers-0.5.11.0
[__6] next goal: array (dependency of wxcore +/-splitbase)
[__6] rejecting: array-0.5.3.0/installed-0.5... (conflict: process =>
base>=4.4 && <4.11, array => base==4.12.0.0/installed-4.1...)
[__6] trying: array-0.5.3.0
[__7] next goal: base (dependency of alsa-gui)
[__7] rejecting: base-4.12.0.0/installed-4.1... (conflict: process =>
base>=4.4 && <4.11)
[__7] rejecting: base-4.12.0.0, base-4.11.1.0, base-4.11.0.0, base-4.10.1.0,
base-4.10.0.0, base-4.9.1.0, base-4.9.0.0, base-4.8.2.0, base-4.8.1.0,
base-4.8.0.0, base-4.7.0.2, base-4.7.0.1, base-4.7.0.0, base-4.6.0.1,
base-4.6.0.0, base-4.5.1.0, base-4.5.0.0, base-4.4.1.0, base-4.4.0.0,
base-4.3.1.0, base-4.3.0.0, base-4.2.0.2, base-4.2.0.1, base-4.2.0.0,
base-4.1.0.0, base-4.0.0.0, base-3.0.3.2, base-3.0.3.1 (constraint from
non-upgradeable package requires installed instance)
[__7] fail (backjumping, conflict set: alsa-gui, base, process)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: process, wxdirect, directory, wxcore,
base, containers, array, alsa-gui