Build #3 for amazonka-iam-policy-0.0.3.1

[all reports]

Package amazonka-iam-policy-0.0.3.1
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-08-14 07:11:31.913233974 UTC
Compiler ghc-8.4.3
OS linux
Arch x86_64
Dependencies aeson-1.4.0.0, base-4.11.1.0, base64-bytestring-1.0.0.1, bytestring-0.10.8.2, hashable-1.2.7.0, scientific-0.3.6.2, text-1.2.3.0, time-1.8.0.2
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring base64-bytestring-1.0.0.1...
Configuring base-compat-0.10.4...
Building base64-bytestring-1.0.0.1...
Building base-compat-0.10.4...
Installed base64-bytestring-1.0.0.1
Configuring dlist-0.8.0.4...
Building dlist-0.8.0.4...
Installed dlist-0.8.0.4
Configuring hashable-1.2.7.0...
Building hashable-1.2.7.0...
Installed base-compat-0.10.4
Configuring integer-logarithms-1.0.2.1...
Building integer-logarithms-1.0.2.1...
Installed integer-logarithms-1.0.2.1
Configuring primitive-0.6.4.0...
Installed hashable-1.2.7.0
Configuring random-1.1...
Building primitive-0.6.4.0...
Building random-1.1...
Installed random-1.1
Configuring tagged-0.8.6...
Building tagged-0.8.6...
Installed tagged-0.8.6
Configuring th-abstraction-0.2.8.0...
Building th-abstraction-0.2.8.0...
Installed th-abstraction-0.2.8.0
Configuring time-locale-compat-0.1.1.4...
Installed primitive-0.6.4.0
Configuring unordered-containers-0.2.9.0...
Building time-locale-compat-0.1.1.4...
Building unordered-containers-0.2.9.0...
Installed time-locale-compat-0.1.1.4
Configuring uuid-types-1.0.3...
Building uuid-types-1.0.3...
Installed uuid-types-1.0.3
Configuring vector-0.12.0.1...
Building vector-0.12.0.1...
Installed unordered-containers-0.2.9.0
Configuring scientific-0.3.6.2...
Building scientific-0.3.6.2...
Installed scientific-0.3.6.2
Configuring attoparsec-0.13.2.2...
Building attoparsec-0.13.2.2...
Installed attoparsec-0.13.2.2
Installed vector-0.12.0.1
Configuring aeson-1.4.0.0...
Building aeson-1.4.0.0...
Installed aeson-1.4.0.0
Configuring amazonka-iam-policy-0.0.3.1...
Building amazonka-iam-policy-0.0.3.1...
Failed to install amazonka-iam-policy-0.0.3.1
Build log ( /home/builder/.cabal/logs/ghc-8.4.3/amazonka-iam-policy-0.0.3.1-Ly7Oky1wY5yK4NEvfg5yAz.log ):
cabal: Entering directory '/tmp/cabal-tmp-29433/amazonka-iam-policy-0.0.3.1'
Configuring amazonka-iam-policy-0.0.3.1...
Preprocessing library for amazonka-iam-policy-0.0.3.1..
Building library for amazonka-iam-policy-0.0.3.1..
[1 of 2] Compiling Amazonka.IAM.Policy ( src/Amazonka/IAM/Policy.hs, dist/build/Amazonka/IAM/Policy.o )
[2 of 2] Compiling Amazonka.IAM.Policy.Lens ( src/Amazonka/IAM/Policy/Lens.hs, dist/build/Amazonka/IAM/Policy/Lens.o )

src/Amazonka/IAM/Policy/Lens.hs:42:1: error:
    Could not find module ‘Data.Profunctor’
    Perhaps you meant
      Data.Bifunctor (from base-4.11.1.0)
      Data.Functor (from base-4.11.1.0)
    Use -v to see a list of the files searched for.
   |
42 | import Data.Profunctor        (dimap)
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

src/Amazonka/IAM/Policy/Lens.hs:43:1: error:
    Could not find module ‘Data.Profunctor.Choice’
    Use -v to see a list of the files searched for.
   |
43 | import Data.Profunctor.Choice (Choice (right'))
   | ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-29433/amazonka-iam-policy-0.0.3.1'
cabal: Error: some packages failed to install:
amazonka-iam-policy-0.0.3.1-Ly7Oky1wY5yK4NEvfg5yAz failed during the building
phase. The exception was:
ExitFailure 1