Build #2 for amqp-utils-0.4.5.1

[all reports]

Package amqp-utils-0.4.5.1
Install DependencyFailed amqp-utils-0.4.5.1
Docs NotTried
Tests NotTried
Time submitted 2021-02-19 18:14:04.773153131 UTC
Compiler ghc-8.10.2
OS linux
Arch x86_64
Dependencies amqp-0.20.0.1, base-4.14.1.0, bytestring-0.10.10.0, connection-0.3.1, containers-0.6.2.1, data-default-class-0.1.2.0, directory-1.3.6.0, hinotify-0.4.1, magic-1.1, network-3.1.2.1, process-1.6.9.0, text-1.2.3.2, time-1.9.3, tls-1.5.5, unix-2.7.2.2, utf8-string-1.0.2, x509-system-1.6.6, amqp-0.20.0.1, base-4.14.1.0, bytestring-0.10.10.0, connection-0.3.1, containers-0.6.2.1, data-default-class-0.1.2.0, directory-1.3.6.0, network-3.1.2.1, process-1.6.9.0, text-1.2.3.2, time-1.9.3, tls-1.5.5, unix-2.7.2.2, utf8-string-1.0.2, x509-system-1.6.6, amqp-0.20.0.1, base-4.14.1.0, bytestring-0.10.10.0, connection-0.3.1, containers-0.6.2.1, data-default-class-0.1.2.0, directory-1.3.6.0, network-3.1.2.1, process-1.6.9.0, text-1.2.3.2, time-1.9.3, tls-1.5.5, utf8-string-1.0.2, x509-system-1.6.6, amqp-0.20.0.1, base-4.14.1.0, bytestring-0.10.10.0, connection-0.3.1, containers-0.6.2.1, data-default-class-0.1.2.0, directory-1.3.6.0, network-3.1.2.1, process-1.6.9.0, text-1.2.3.2, time-1.9.3, tls-1.5.5, unix-2.7.2.2, utf8-string-1.0.2, x509-system-1.6.6
Flags none

Build log

[view raw]

Resolving dependencies...
Starting     clock-0.8.2
Starting     cereal-0.5.8.1
Starting     base-orphans-0.8.4
Starting     basement-0.0.11
Building     clock-0.8.2
Building     cereal-0.5.8.1
Building     base-orphans-0.8.4
Building     basement-0.0.11
Completed    clock-0.8.2
Starting     data-binary-ieee754-0.4.4
Building     data-binary-ieee754-0.4.4
Completed    data-binary-ieee754-0.4.4
Starting     data-default-class-0.1.2.0
Building     data-default-class-0.1.2.0
Completed    base-orphans-0.8.4
Starting     hashable-1.3.1.0
Building     hashable-1.3.1.0
Completed    data-default-class-0.1.2.0
Starting     hourglass-0.2.12
Building     hourglass-0.2.12
Completed    cereal-0.5.8.1
Starting     magic-1.1
Failed to install magic-1.1
Build log ( /home/builder/.cabal/logs/ghc-8.10.2/magic-1.1-1RoyXuVqQ6zBGAsTPFSblk.log ):
cabal: Entering directory '/tmp/cabal-tmp-5212/magic-1.1'
Configuring magic-1.1...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: magic
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-5212/magic-1.1'
Starting     network-3.1.2.1
Completed    hashable-1.3.1.0
Building     network-3.1.2.1
Completed    hourglass-0.2.12
Completed    network-3.1.2.1
Completed    basement-0.0.11
cabal: Error: some packages failed to install:
amqp-utils-0.4.5.1-85n9I7kllnVDvw9n7tjB95 depends on amqp-utils-0.4.5.1 which
failed to install.
magic-1.1-1RoyXuVqQ6zBGAsTPFSblk failed during the configure step. The
exception was:
ExitFailure 1