Build #2 for beam-mysql-0.2.0.0

[all reports]

Package beam-mysql-0.2.0.0
Install DependencyFailed beam-mysql-0.2.0.0
Docs NotTried
Tests NotTried
Time submitted 2019-03-19 05:58:38.604364445 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies aeson-1.4.2.0, attoparsec-0.13.2.2, base-4.12.0.0, beam-core-0.8.0.0, bytestring-0.10.8.2, case-insensitive-1.2.0.11, free-5.1, hashable-1.2.7.0, mtl-2.2.2, mysql-0.1.7, network-uri-2.6.1.0, scientific-0.3.6.2, text-1.2.3.1, time-1.8.0.2
Flags -werror

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     StateVar-1.1.1.1
Starting     Only-0.1
Starting     base-orphans-0.8
Starting     base-compat-0.10.5
Building     StateVar-1.1.1.1
Building     Only-0.1
Building     base-orphans-0.8
Building     base-compat-0.10.5
Completed    base-orphans-0.8
Starting     cabal-doctest-1.0.6
Completed    StateVar-1.1.1.1
Starting     dlist-0.8.0.5
Completed    Only-0.1
Starting     finite-typelits-0.1.4.2
Building     cabal-doctest-1.0.6
Building     dlist-0.8.0.5
Building     finite-typelits-0.1.4.2
Completed    finite-typelits-0.1.4.2
Starting     hashable-1.2.7.0
Completed    cabal-doctest-1.0.6
Starting     integer-logarithms-1.0.2.2
Completed    dlist-0.8.0.5
Starting     microlens-0.4.10
Building     hashable-1.2.7.0
Building     integer-logarithms-1.0.2.2
Building     microlens-0.4.10
Completed    base-compat-0.10.5
Starting     mysql-0.1.7
Completed    integer-logarithms-1.0.2.2
Starting     network-uri-2.6.1.0
Building     network-uri-2.6.1.0
Completed    microlens-0.4.10
Starting     primitive-0.6.4.0
Completed    hashable-1.2.7.0
Starting     random-1.1
Failed to install mysql-0.1.7
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/mysql-0.1.7-2akJKk9UoN98FN0HKbIl2c.log ):
cabal: Entering directory '/tmp/cabal-tmp-20645/mysql-0.1.7'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-20645/mysql-0.1.7/dist/setup/setup.hs, /tmp/cabal-tmp-20645/mysql-0.1.7/dist/setup/Main.o )
Linking /tmp/cabal-tmp-20645/mysql-0.1.7/dist/setup/setup ...
Configuring mysql-0.1.7...
setup: The program 'mysql_config' is required but it could not be found

cabal: Leaving directory '/tmp/cabal-tmp-20645/mysql-0.1.7'
Starting     semigroups-0.18.5
Building     primitive-0.6.4.0
Building     random-1.1
Building     semigroups-0.18.5
Completed    semigroups-0.18.5
Completed    network-uri-2.6.1.0
Completed    random-1.1
Completed    primitive-0.6.4.0
cabal: Error: some packages failed to install:
beam-mysql-0.2.0.0-1ztNtZZexk925CduIzMZa depends on beam-mysql-0.2.0.0 which
failed to install.
mysql-0.1.7-2akJKk9UoN98FN0HKbIl2c failed during the configure step. The
exception was:
ExitFailure 1