Build #3 for beam-sqlite-0.3.1.0

[all reports]

Package beam-sqlite-0.3.1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2018-04-13 23:47:56.217716701 UTC
Compiler ghc-8.2.2
OS linux
Arch x86_64
Dependencies aeson-1.2.4.0, attoparsec-0.13.2.0, base-4.10.1.0, beam-core-0.7.2.0, beam-migrate-0.3.1.0, bytestring-0.10.8.2, dlist-0.8.0.4, free-5.0.1, hashable-1.2.6.1, mtl-2.2.1, network-uri-2.6.1.0, scientific-0.3.5.2, sqlite-simple-0.4.15.0, text-1.2.2.2, time-1.8.0.2, unix-2.7.2.2
Flags -werror

Build log

[view raw]

Resolving dependencies...
Configuring OneTuple-0.2.1...
Configuring Only-0.1...
Building Only-0.1...
Building OneTuple-0.2.1...
Installed OneTuple-0.2.1
Configuring base-compat-0.9.3...
Installed Only-0.1
Configuring base-orphans-0.7...
Building base-compat-0.9.3...
Building base-orphans-0.7...
Installed base-orphans-0.7
Configuring blaze-builder-0.4.1.0...
Installed base-compat-0.9.3
Configuring cabal-doctest-1.0.6...
Building blaze-builder-0.4.1.0...
Building cabal-doctest-1.0.6...
Installed blaze-builder-0.4.1.0
Configuring dependent-sum-0.4...
Installed cabal-doctest-1.0.6
Configuring dlist-0.8.0.4...
Building dependent-sum-0.4...
Building dlist-0.8.0.4...
Installed dependent-sum-0.4
Configuring finite-typelits-0.1.3.0...
Building finite-typelits-0.1.3.0...
Installed dlist-0.8.0.4
Configuring microlens-0.4.9.1...
Building microlens-0.4.9.1...
Installed finite-typelits-0.1.3.0
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Installed microlens-0.4.9.1
Configuring polyparse-1.12...
Installed old-locale-1.0.0.7
Configuring pqueue-1.4.1.1...
Building polyparse-1.12...
Building pqueue-1.4.1.1...
Installed pqueue-1.4.1.1
Configuring semigroups-0.18.4...
Building semigroups-0.18.4...
Installed polyparse-1.12
Configuring th-abstraction-0.2.6.0...
Building th-abstraction-0.2.6.0...
Installed semigroups-0.18.4
Configuring time-locale-compat-0.1.1.4...
Building time-locale-compat-0.1.1.4...
Installed time-locale-compat-0.1.1.4
Configuring transformers-compat-0.6.1.5...
Building transformers-compat-0.6.1.5...
Installed th-abstraction-0.2.6.0
Configuring uuid-types-1.0.3...
Building uuid-types-1.0.3...
Installed transformers-compat-0.6.1.5
Configuring indexed-list-literals-0.1.0.1...
Building indexed-list-literals-0.1.0.1...
Installed uuid-types-1.0.3
Configuring dependent-map-0.2.4.0...
Building dependent-map-0.2.4.0...
Installed indexed-list-literals-0.1.0.1
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Installed dependent-map-0.2.4.0
Configuring blaze-textual-0.2.1.0...
Building blaze-textual-0.2.1.0...
Installed old-time-1.1.0.3
Configuring direct-sqlite-2.3.23...
Building direct-sqlite-2.3.23...
Installed blaze-textual-0.2.1.0
Configuring transformers-base-0.4.5.2...
Building transformers-base-0.4.5.2...
Installed transformers-base-0.4.5.2
Configuring tagged-0.8.5...
Building tagged-0.8.5...
Installed tagged-0.8.5
Configuring exceptions-0.10.0...
Building exceptions-0.10.0...
Installed exceptions-0.10.0
Configuring contravariant-1.4.1...
Building contravariant-1.4.1...
Installed contravariant-1.4.1
Configuring vector-sized-1.0.0.0...
Building vector-sized-1.0.0.0...
Installed direct-sqlite-2.3.23
Configuring cpphs-1.20.8...
Building cpphs-1.20.8...
Installed vector-sized-1.0.0.0
Configuring distributive-0.5.3...
Installed cpphs-1.20.8
Configuring aeson-1.2.4.0...
Building distributive-0.5.3...
Building aeson-1.2.4.0...
Installed distributive-0.5.3
Configuring sqlite-simple-0.4.15.0...
Building sqlite-simple-0.4.15.0...
Installed sqlite-simple-0.4.15.0
Configuring haskell-src-exts-1.20.2...
Building haskell-src-exts-1.20.2...
Installed aeson-1.2.4.0
Configuring comonad-5.0.3...
Building comonad-5.0.3...
Installed comonad-5.0.3
Configuring bifunctors-5.5.2...
Building bifunctors-5.5.2...
Installed bifunctors-5.5.2
Configuring semigroupoids-5.2.2...
Building semigroupoids-5.2.2...
Installed semigroupoids-5.2.2
Configuring profunctors-5.2.2...
Building profunctors-5.2.2...
Installed profunctors-5.2.2
Configuring free-5.0.1...
Building free-5.0.1...
Installed free-5.0.1
Configuring beam-core-0.7.2.0...
Building beam-core-0.7.2.0...
Installed beam-core-0.7.2.0
Installed haskell-src-exts-1.20.2
Configuring beam-migrate-0.3.1.0...
Building beam-migrate-0.3.1.0...
Installed beam-migrate-0.3.1.0
Configuring beam-sqlite-0.3.1.0...
Building beam-sqlite-0.3.1.0...
Failed to install beam-sqlite-0.3.1.0
Build log ( /home/builder/.cabal/logs/ghc-8.2.2/beam-sqlite-0.3.1.0-7dCdooynj9nLefJMi9asR4.log ):
cabal: Entering directory '/tmp/cabal-tmp-2218/beam-sqlite-0.3.1.0'
Configuring beam-sqlite-0.3.1.0...
Preprocessing library for beam-sqlite-0.3.1.0..
Building library for beam-sqlite-0.3.1.0..
[1 of 4] Compiling Database.Beam.Sqlite.Syntax ( Database/Beam/Sqlite/Syntax.hs, dist/build/Database/Beam/Sqlite/Syntax.o )

Database/Beam/Sqlite/Syntax.hs:698:10: error:
    • No instance for (Data.Semigroup.Semigroup
                         (CustomSqlSyntax SqliteExpressionSyntax))
        arising from the superclasses of an instance declaration
    • In the instance declaration for
        ‘IsCustomSqlSyntax SqliteExpressionSyntax’
    |
698 | instance IsCustomSqlSyntax SqliteExpressionSyntax where
    |          ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cabal: Leaving directory '/tmp/cabal-tmp-2218/beam-sqlite-0.3.1.0'
cabal: Error: some packages failed to install:
beam-sqlite-0.3.1.0-7dCdooynj9nLefJMi9asR4 failed during the building phase.
The exception was:
ExitFailure 1