Build #1 for bit-array-0.1.2

[all reports]

Package bit-array-0.1.2
Install InstallOk
Docs Ok
Tests NotTried
Time submitted 2016-10-01 12:16:18.60663 UTC
Compiler ghc-8.0.1.20160701
OS linux
Arch x86_64
Dependencies base-4.9.0.0, numeric-qq-0.1.3
Flags none

Build log

[view raw]

Resolving dependencies...
cabal: Entering directory '/tmp/cabal-tmp-7526/loch-th-0.2.1'
Configuring loch-th-0.2.1...
Building loch-th-0.2.1...
Preprocessing library loch-th-0.2.1...
[1 of 1] Compiling Debug.Trace.LocationTH ( Debug/Trace/LocationTH.hs, dist/build/Debug/Trace/LocationTH.o )
Running Haddock for loch-th-0.2.1...
Running hscolour for loch-th-0.2.1...
Preprocessing library loch-th-0.2.1...
Preprocessing library loch-th-0.2.1...
Haddock coverage:
 100% (  9 /  9) in 'Debug.Trace.LocationTH'
Documentation created: dist/doc/html/loch-th/index.html,
dist/doc/html/loch-th/loch-th.txt
Creating package registration file:
/tmp/pkgConf-loch-th-0.22145174067468703135.1
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-8.0.1.20160701/loch-th-0.2.1-HeAYtId6vjrGaOk8hiaVQf
Registering loch-th-0.2.1...
cabal: Leaving directory '/tmp/cabal-tmp-7526/loch-th-0.2.1'
Installed loch-th-0.2.1
cabal: Entering directory '/tmp/cabal-tmp-7526/placeholders-0.1'
Configuring placeholders-0.1...
Building placeholders-0.1...
Preprocessing library placeholders-0.1...
[1 of 1] Compiling Development.Placeholders ( src/Development/Placeholders.hs, dist/build/Development/Placeholders.o )

src/Development/Placeholders.hs:60:19: warning: [-Wdeprecations]
    In the use of ‘report’
    (imported from Language.Haskell.TH, but defined in Language.Haskell.TH.Syntax):
    Deprecated: "Use reportError or reportWarning instead"
Running Haddock for placeholders-0.1...
Running hscolour for placeholders-0.1...
Preprocessing library placeholders-0.1...
Preprocessing library placeholders-0.1...

src/Development/Placeholders.hs:60:19: warning: [-Wdeprecations]
    In the use of ‘report’
    (imported from Language.Haskell.TH, but defined in Language.Haskell.TH.Syntax):
    Deprecated: "Use reportError or reportWarning instead"
Haddock coverage:
 100% ( 10 / 10) in 'Development.Placeholders'
Documentation created: dist/doc/html/placeholders/index.html,
dist/doc/html/placeholders/placeholders.txt
Creating package registration file:
/tmp/pkgConf-placeholders-09439477391984210012.1
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-8.0.1.20160701/placeholders-0.1-Jaw2KlzCEKg3F0WJS0H8eo
Registering placeholders-0.1...
cabal: Leaving directory '/tmp/cabal-tmp-7526/placeholders-0.1'
Installed placeholders-0.1
Downloading numeric-qq-0.1.3...
cabal: Entering directory '/tmp/cabal-tmp-7526/numeric-qq-0.1.3'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/numeric-qq-0.1.3/dist/setup/setup.hs, /tmp/cabal-tmp-7526/numeric-qq-0.1.3/dist/setup/Main.o )

/tmp/cabal-tmp-7526/numeric-qq-0.1.3/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/numeric-qq-0.1.3/dist/setup/setup ...
Configuring numeric-qq-0.1.3...
Building numeric-qq-0.1.3...
Preprocessing library numeric-qq-0.1.3...
[1 of 2] Compiling NumericQQ.Prelude ( library/NumericQQ/Prelude.hs, dist/build/NumericQQ/Prelude.o )
[2 of 2] Compiling NumericQQ        ( library/NumericQQ.hs, dist/build/NumericQQ.o )

library/NumericQQ.hs:49:11: warning: [-Wmissing-fields]
    • Fields of ‘QuasiQuoter’ not initialised: quotePat, quoteType,
                                               quoteDec
    • In the expression: QuasiQuoter {quoteExp = exp}
      In an equation for ‘qq’:
          qq base
            = QuasiQuoter {quoteExp = exp}
            where
                exp s
                  = case parse base s of {
                      Nothing
                        -> fail
                           $ "A string \""
                             <> s <> "\" cannot be parsed as a base-" <> show base <> " number"
                      Just i -> return $ LitE (IntegerL (fromIntegral i)) }
Running Haddock for numeric-qq-0.1.3...
Running hscolour for numeric-qq-0.1.3...
Preprocessing library numeric-qq-0.1.3...
Preprocessing library numeric-qq-0.1.3...

library/NumericQQ.hs:49:11: warning: [-Wmissing-fields]
    • Fields of ‘QuasiQuoter’ not initialised: quotePat, quoteType,
                                               quoteDec
    • In the expression: QuasiQuoter {quoteExp = exp}
      In an equation for ‘qq’:
          qq base
            = QuasiQuoter {quoteExp = exp}
            where
                exp s
                  = case parse base s of {
                      Nothing
                        -> fail
                           $ "A string \""
                             <> s <> "\" cannot be parsed as a base-" <> show base <> " number"
                      Just i -> return $ LitE (IntegerL (fromIntegral i)) }
Haddock coverage:
Warning: NumericQQ.Prelude: Could not find documentation for exported module: Exports
   0% (  0 /  3) in 'NumericQQ.Prelude'
  Missing documentation for:
    Module header
    bug (library/NumericQQ/Prelude.hs:59)
    bottom (library/NumericQQ/Prelude.hs:63)
  75% (  3 /  4) in 'NumericQQ'
  Missing documentation for:
    Module header
Documentation created: dist/doc/html/numeric-qq/index.html,
dist/doc/html/numeric-qq/numeric-qq.txt
Creating package registration file:
/tmp/pkgConf-numeric-qq-0.117132582701573363368.3
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-8.0.1.20160701/numeric-qq-0.1.3-JK3CJJSVqrjCalrcH0Jnqv
Registering numeric-qq-0.1.3...
cabal: Leaving directory '/tmp/cabal-tmp-7526/numeric-qq-0.1.3'
Installed numeric-qq-0.1.3
Downloading bit-array-0.1.2...
cabal: Entering directory '/tmp/cabal-tmp-7526/bit-array-0.1.2'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Configuring bit-array-0.1.2...
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Building bit-array-0.1.2...
Preprocessing library bit-array-0.1.2...
[1 of 3] Compiling BitArray.Prelude ( library/BitArray/Prelude.hs, dist/build/BitArray/Prelude.o )
[2 of 3] Compiling BitArray.Parser  ( library/BitArray/Parser.hs, dist/build/BitArray/Parser.o )
[3 of 3] Compiling BitArray         ( library/BitArray.hs, dist/build/BitArray.o )
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Running Haddock for bit-array-0.1.2...
Running hscolour for bit-array-0.1.2...
Preprocessing library bit-array-0.1.2...
Preprocessing library bit-array-0.1.2...
Haddock coverage:
Warning: BitArray.Prelude: Could not find documentation for exported module: Exports
   0% (  0 /  2) in 'BitArray.Prelude'
  Missing documentation for:
    Module header
    bool (library/BitArray/Prelude.hs:52)
   0% (  0 /  4) in 'BitArray.Parser'
  Missing documentation for:
    Module header
    digits (library/BitArray/Parser.hs:8)
    bitIndexes (library/BitArray/Parser.hs:11)
    bits (library/BitArray/Parser.hs:21)
  90% ( 19 / 21) in 'BitArray'
  Missing documentation for:
    Module header
     (library/BitArray.hs:61)
Warning: BitArray: could not find link destinations for:
    unsafeIndex unsafeRangeSize
Documentation created: dist/doc/html/bit-array/index.html,
dist/doc/html/bit-array/bit-array.txt
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Creating package registration file:
/tmp/pkgConf-bit-array-0.12147469841438792350.2
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Installing library in
/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-8.0.1.20160701/bit-array-0.1.2-CWQbNqLr0wnDfVii21wplc
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs, /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/Main.o )

/tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup.hs:47:69: warning: [-Wdeprecations]
    In the use of type constructor or class ‘InstalledPackageId’
    (imported from Distribution.Package):
    Deprecated: "Use UnitId instead"
Linking /tmp/cabal-tmp-7526/bit-array-0.1.2/dist/setup/setup ...
Registering bit-array-0.1.2...
cabal: Leaving directory '/tmp/cabal-tmp-7526/bit-array-0.1.2'
Installed bit-array-0.1.2