Build #3 for bzlib-conduit-0.3.0.2

[all reports]

Package bzlib-conduit-0.3.0.2
Install ConfigureFailed
Docs NotTried
Tests NotTried
Time submitted 2019-08-06 11:21:05.288369828 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies base-4.12.0.0, bindings-DSL-1.0.25, bytestring-0.10.8.2, conduit-1.3.1.1, data-default-class-0.1.2.0, mtl-2.2.2, resourcet-1.2.2
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
Starting     data-default-class-0.1.2.0
Starting     bindings-DSL-1.0.25
Starting     hashable-1.3.0.0
Starting     primitive-0.7.0.0
Building     data-default-class-0.1.2.0
Building     bindings-DSL-1.0.25
Building     hashable-1.3.0.0
Building     primitive-0.7.0.0
Completed    bindings-DSL-1.0.25
Starting     split-0.2.3.3
Completed    data-default-class-0.1.2.0
Starting     transformers-compat-0.6.5
Building     split-0.2.3.3
Building     transformers-compat-0.6.5
Completed    hashable-1.3.0.0
Starting     unliftio-core-0.1.2.0
Completed    split-0.2.3.3
Starting     unordered-containers-0.2.10.0
Building     unliftio-core-0.1.2.0
Building     unordered-containers-0.2.10.0
Completed    transformers-compat-0.6.5
Starting     exceptions-0.10.2
Completed    unliftio-core-0.1.2.0
Building     exceptions-0.10.2
Completed    exceptions-0.10.2
Completed    primitive-0.7.0.0
Starting     resourcet-1.2.2
Starting     vector-0.12.0.3
Building     vector-0.12.0.3
Building     resourcet-1.2.2
Completed    unordered-containers-0.2.10.0
Completed    resourcet-1.2.2
Completed    vector-0.12.0.3
Starting     vector-algorithms-0.8.0.1
Building     vector-algorithms-0.8.0.1
Completed    vector-algorithms-0.8.0.1
Starting     mono-traversable-1.0.11.0
Building     mono-traversable-1.0.11.0
Completed    mono-traversable-1.0.11.0
Starting     conduit-1.3.1.1
Building     conduit-1.3.1.1
Completed    conduit-1.3.1.1
Starting     bzlib-conduit-0.3.0.2
Failed to install bzlib-conduit-0.3.0.2
Build log ( /home/builder/.cabal/logs/ghc-8.6.3/bzlib-conduit-0.3.0.2-L7ReoiiYQc8FcUoKYamZN.log ):
cabal: Entering directory '/tmp/cabal-tmp-24972/bzlib-conduit-0.3.0.2'
Configuring bzlib-conduit-0.3.0.2...
cabal: Missing dependency on a foreign library:
* Missing (or bad) C library: bz2
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.If the
library file does exist, it may contain errors that are caught by the C
compiler at the preprocessing stage. In this case you can re-run configure
with the verbosity flag -v3 to see the error messages.

cabal: Leaving directory '/tmp/cabal-tmp-24972/bzlib-conduit-0.3.0.2'
cabal: Error: some packages failed to install:
bzlib-conduit-0.3.0.2-L7ReoiiYQc8FcUoKYamZN failed during the configure step.
The exception was:
ExitFailure 1