Metadata revisions for cabal-plan-0.3.0.0

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User SHA256
-r1 2018-04-13T19:25:35Z HerbertValerioRiedel 9853240528c92c9c76702a42ea84e77a345814aae83470df45526be14b94b5f5
  • Changed tested-with from

    ghc ==8.2.1: ghc ==8.0.2: ghc ==7.10.3: ghc ==7.8.4: ghc ==7.6.3
    to
    ghc ==8.4.1: ghc ==8.2.2: ghc ==8.0.2: ghc ==7.10.3: ghc ==7.8.4: ghc ==7.6.3

  • Changed bug-reports from

    https://github.com/hvr/cabal-plan/issues
    to
    https://github.com/haskell-hvr/cabal-plan/issues

  • Changed the library component's library dependency on 'aeson' from

    ^>=1.2.0
    to
    ^>=1.2.0 || ^>=1.3.0

  • Changed the library component's library dependency on 'base' from

    (>=4.6 && <4.10) || ^>=4.10
    to
    (>=4.6 && <4.10) || ^>=4.10 || ^>=4.11

  • Changed the library 'topograph' component's library dependency on 'base' from

    (>=4.6 && <4.10) || ^>=4.10
    to
    (>=4.6 && <4.10) || ^>=4.10 || ^>=4.11

  • Changed the library 'topograph' component's library dependency on 'base-compat' from

    ^>=0.9.3
    to
    ^>=0.9.3 || ^>=0.10.1

  • Changed the library 'topograph' component's library dependency on 'base-orphans' from

    ^>=0.6
    to
    ^>=0.6 || ^>=0.7

  • Changed the executable 'cabal-plan' component's library dependency on 'ansi-terminal' from

    ^>=0.6.2
    to
    ^>=0.6.2 || ^>=0.8.0.2

-r0 2018-01-07T23:02:40Z HerbertValerioRiedel 57f62116e46c15ae822de8af4095e9968d2673d1c97762ed9c59a73f3ef945d4