Build #1 for cabal2ebuild-0.0.15.9

[all reports]

Package cabal2ebuild-0.0.15.9
Install InstallOk
Docs Ok
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies filepath-1.3.0.1, directory-1.2.0.1, curl-1.3.8, base-4.6.0.1, Cabal-1.18.1.3
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring curl-1.3.8...
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
configure: creating ./config.status
config.status: creating curl.buildinfo
Building curl-1.3.8...
Preprocessing library curl-1.3.8...
[1 of 8] Compiling Network.Curl.Debug ( Network/Curl/Debug.hs, dist/build/Network/Curl/Debug.o )
[2 of 8] Compiling Network.Curl.Code ( Network/Curl/Code.hs, dist/build/Network/Curl/Code.o )
[3 of 8] Compiling Network.Curl.Types ( Network/Curl/Types.hs, dist/build/Network/Curl/Types.o )
[4 of 8] Compiling Network.Curl.Info ( Network/Curl/Info.hs, dist/build/Network/Curl/Info.o )
[5 of 8] Compiling Network.Curl.Post ( Network/Curl/Post.hs, dist/build/Network/Curl/Post.o )
[6 of 8] Compiling Network.Curl.Opts ( Network/Curl/Opts.hs, dist/build/Network/Curl/Opts.o )
[7 of 8] Compiling Network.Curl.Easy ( Network/Curl/Easy.hs, dist/build/Network/Curl/Easy.o )
[8 of 8] Compiling Network.Curl     ( Network/Curl.hs, dist/build/Network/Curl.o )
In-place registering curl-1.3.8...
Running Haddock for curl-1.3.8...
Running hscolour for curl-1.3.8...
Preprocessing library curl-1.3.8...
Preprocessing library curl-1.3.8...
Haddock coverage:
  50% (  1 /  2) in 'Network.Curl.Debug'
  33% (  1 /  3) in 'Network.Curl.Code'
  27% (  4 / 15) in 'Network.Curl.Types'
  25% (  1 /  4) in 'Network.Curl.Info'
   9% (  1 / 11) in 'Network.Curl.Post'
   3% (  1 / 29) in 'Network.Curl.Opts'
  20% (  2 / 10) in 'Network.Curl.Easy'
  67% ( 26 / 39) in 'Network.Curl'
Warning: Network.Curl.Types: could not find link destinations for:
    Network.Curl.Types.Curl_
Documentation created: dist/doc/html/curl/index.html
Installing library in
/srv/hackage/var/build/tmp-install/lib/x86_64-linux-ghc-7.6.3/curl-1.3.8
Registering curl-1.3.8...
Installed curl-1.3.8
Downloading cabal2ebuild-0.0.15.9...
Configuring cabal2ebuild-0.0.15.9...
Building cabal2ebuild-0.0.15.9...
Preprocessing library cabal2ebuild-0.0.15.9...
[1 of 2] Compiling Gentoo.Depend    ( src-lib/Gentoo/Depend.hs, dist/build/Gentoo/Depend.o )

src-lib/Gentoo/Depend.hs:69:15: Warning:
    In the use of data constructor `AnyVersion'
    (imported from Distribution.Version):
    Deprecated: "Use 'anyVersion', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:70:17: Warning:
    In the use of data constructor `UnionVersionRanges'
    (imported from Distribution.Version):
    Deprecated: "use 'unionVersionRanges', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:74:17: Warning:
    In the use of data constructor `ThisVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'thisVersion', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:75:17: Warning:
    In the use of data constructor `LaterVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'laterVersion', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:76:17: Warning:
    In the use of data constructor `EarlierVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'earlierVersion', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:77:17: Warning:
    In the use of data constructor `IntersectVersionRanges'
    (imported from Distribution.Version):
    Deprecated: "use 'intersectVersionRanges', 'foldVersionRange' or 'asVersionIntervals'"

src-lib/Gentoo/Depend.hs:78:17: Warning:
    In the use of data constructor `WildcardVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'anyVersion', 'foldVersionRange' or 'asVersionIntervals'"
[2 of 2] Compiling Gentoo.Cabal2Ebuild ( src-lib/Gentoo/Cabal2Ebuild.hs, dist/build/Gentoo/Cabal2Ebuild.o )
In-place registering cabal2ebuild-0.0.15.9...
Preprocessing executable 'cabal2ebuild' for cabal2ebuild-0.0.15.9...
[1 of 1] Compiling Main             ( src-exec/cabal2ebuild.hs, dist/build/cabal2ebuild/cabal2ebuild-tmp/Main.o )
Linking dist/build/cabal2ebuild/cabal2ebuild ...
Preprocessing executable 'hackage2ebuild' for cabal2ebuild-0.0.15.9...
[1 of 1] Compiling Main             ( src-exec/hackage2ebuild.hs, dist/build/hackage2ebuild/hackage2ebuild-tmp/Main.o )
Linking dist/build/hackage2ebuild/hackage2ebuild ...
Running Haddock for cabal2ebuild-0.0.15.9...
Running hscolour for cabal2ebuild-0.0.15.9...
Preprocessing library cabal2ebuild-0.0.15.9...
Preprocessing executable 'cabal2ebuild' for cabal2ebuild-0.0.15.9...
Preprocessing executable 'hackage2ebuild' for cabal2ebuild-0.0.15.9...
Preprocessing library cabal2ebuild-0.0.15.9...
Warning: The documentation for the following packages are not installed. No
links will be generated to these packages: Cabal-1.18.1.3

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:69:15: Warning:
    In the use of data constructor `AnyVersion'
    (imported from Distribution.Version):
    Deprecated: "Use 'anyVersion', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:70:17: Warning:
    In the use of data constructor `UnionVersionRanges'
    (imported from Distribution.Version):
    Deprecated: "use 'unionVersionRanges', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:74:17: Warning:
    In the use of data constructor `ThisVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'thisVersion', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:75:17: Warning:
    In the use of data constructor `LaterVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'laterVersion', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:76:17: Warning:
    In the use of data constructor `EarlierVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'earlierVersion', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:77:17: Warning:
    In the use of data constructor `IntersectVersionRanges'
    (imported from Distribution.Version):
    Deprecated: "use 'intersectVersionRanges', 'foldVersionRange' or 'asVersionIntervals'"

dist/build/tmp-4042/src-lib/Gentoo/Depend.hs:78:17: Warning:
    In the use of data constructor `WildcardVersion'
    (imported from Distribution.Version):
    Deprecated: "use 'anyVersion', 'foldVersionRange' or 'asVersionIntervals'"
Haddock coverage:
   0% (  0 /  3) in 'Gentoo.Depend'
   0% (  0 /  2) in 'Gentoo.Cabal2Ebuild'
Documentation created: dist/doc/html/cabal2ebuild/index.html
Preprocessing executable 'cabal2ebuild' for cabal2ebuild-0.0.15.9...
Preprocessing executable 'hackage2ebuild' for cabal2ebuild-0.0.15.9...
Installing library in
/srv/hackage/var/build/tmp-install/lib/x86_64-linux-ghc-7.6.3/cabal2ebuild-0.0.15.9
Installing executable(s) in /srv/hackage/var/build/tmp-install/bin
Warning: The directory /srv/hackage/var/build/tmp-install/bin is not in the
system search path.
Registering cabal2ebuild-0.0.15.9...
Installed cabal2ebuild-0.0.15.9