Build #8 for cakyrespa-0.0.22

[all reports]

Package cakyrespa-0.0.22
Install DependencyFailed lojbanParser-0.1.9.2
Docs NotTried
Tests NotTried
Time submitted 2016-12-23 18:21:25.006191 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies GLUT-2.7.0.10, base-4.9.0.0, gluturtle-0.0.58.1, lojbanParser-0.1.9.2, yjsvg-0.2.0.0, yjtools-0.9.18
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring ObjectName-1.1.0.1...
Configuring fixed-0.2.1.1...
Building ObjectName-1.1.0.1...
Building fixed-0.2.1.1...
Installed ObjectName-1.1.0.1
Configuring half-0.2.2.3...
Configuring lojbanParser-0.1.9.2...
Installed fixed-0.2.1.1
Building half-0.2.2.3...
Building lojbanParser-0.1.9.2...
Configuring mtl-2.2.1...
Failed to install lojbanParser-0.1.9.2
Build log ( /home/builder/.cabal/logs/lojbanParser-0.1.9.2.log ):
cabal: Entering directory '/tmp/cabal-tmp-18079/lojbanParser-0.1.9.2'
Configuring lojbanParser-0.1.9.2...
Building lojbanParser-0.1.9.2...
Preprocessing library lojbanParser-0.1.9.2...
[1 of 6] Compiling Pos              ( src/Pos.hs, dist/build/Pos.o )

src/Pos.hs:8:1: warning: [-Wtabs]
    Tab character found here, and in 27 further locations.
    Please use spaces instead.
[2 of 6] Compiling Parse            ( src/Parse.hs, dist/build/Parse.o )

src/Parse.hs:49:10: error:
    • Could not deduce (Applicative (Parser d))
        arising from the superclasses of an instance declaration
      from the context: Derivs d
        bound by the instance declaration at src/Parse.hs:49:10-37
    • In the instance declaration for ‘Monad (Parser d)’
cabal: Leaving directory '/tmp/cabal-tmp-18079/lojbanParser-0.1.9.2'
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed half-0.2.2.3
Building old-locale-1.0.0.7...
Configuring random-1.1...
Installed old-locale-1.0.0.7
Building random-1.1...
Configuring stm-2.4.4.1...
Installed mtl-2.2.1
Building stm-2.4.4.1...
Configuring yjtools-0.9.18...
Installed random-1.1
Building yjtools-0.9.18...
Configuring text-1.2.2.1...
Installed stm-2.4.4.1
Building text-1.2.2.1...
Installed yjtools-0.9.18
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Configuring StateVar-1.1.0.4...
Installed old-time-1.1.0.3
Building StateVar-1.1.0.4...
Installed StateVar-1.1.0.4
Installed text-1.2.2.1
Configuring convertible-1.1.1.0...
Configuring polyparse-1.12...
Building convertible-1.1.1.0...
Building polyparse-1.12...
Configuring OpenGLRaw-3.2.4.0...
Installed polyparse-1.12
Building OpenGLRaw-3.2.4.0...
Installed convertible-1.1.1.0
Configuring HaXml-1.24.1...
Building HaXml-1.24.1...
Installed HaXml-1.24.1
Configuring yjsvg-0.2.0.0...
Building yjsvg-0.2.0.0...
Installed yjsvg-0.2.0.0
Installed OpenGLRaw-3.2.4.0
Configuring GLURaw-2.0.0.3...
Building GLURaw-2.0.0.3...
Installed GLURaw-2.0.0.3
Configuring OpenGL-3.0.1.0...
Building OpenGL-3.0.1.0...
Installed OpenGL-3.0.1.0
Configuring GLUT-2.7.0.10...
Building GLUT-2.7.0.10...
Installed GLUT-2.7.0.10
Configuring gluturtle-0.0.58.1...
Building gluturtle-0.0.58.1...
Installed gluturtle-0.0.58.1
cabal: Error: some packages failed to install:
cakyrespa-0.0.22 depends on lojbanParser-0.1.9.2 which failed to install.
lojbanParser-0.1.9.2 failed during the building phase. The exception was:
ExitFailure 1