Build #8 for darcs-buildpackage-0.5.11

[all reports]

Package darcs-buildpackage-0.5.11
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2017-01-04 04:45:04.826133 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies ConfigFile-1.1.4, MissingH-1.4.0.1, base-4.9.0.0, hslogger-1.2.10, network-2.6.3.1, parsec-3.1.11, regex-compat-0.95.1, unix-2.7.2.0, ConfigFile-1.1.4, MissingH-1.4.0.1, base-4.9.0.0, hslogger-1.2.10, network-2.6.3.1, parsec-3.1.11, regex-compat-0.95.1, unix-2.7.2.0, ConfigFile-1.1.4, MissingH-1.4.0.1, base-4.9.0.0, hslogger-1.2.10, network-2.6.3.1, parsec-3.1.11, regex-compat-0.95.1, unix-2.7.2.0, ConfigFile-1.1.4, MissingH-1.4.0.1, base-4.9.0.0, hslogger-1.2.10, network-2.6.3.1, parsec-3.1.11, regex-compat-0.95.1, unix-2.7.2.0, ConfigFile-1.1.4, MissingH-1.4.0.1, base-4.9.0.0, hslogger-1.2.10, network-2.6.3.1, parsec-3.1.11, regex-compat-0.95.1, unix-2.7.2.0
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring call-stack-0.1.0...
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Building call-stack-0.1.0...
Installed call-stack-0.1.0
Configuring old-locale-1.0.0.7...
Building old-locale-1.0.0.7...
Configuring network-2.6.3.1...
Installed old-locale-1.0.0.7
Configuring random-1.1...
Installed mtl-2.2.1
Building random-1.1...
Building network-2.6.3.1...
Configuring HUnit-1.5.0.0...
Installed random-1.1
Building HUnit-1.5.0.0...
Configuring text-1.2.2.1...
Installed HUnit-1.5.0.0
Building text-1.2.2.1...
Installed network-2.6.3.1
Configuring old-time-1.1.0.3...
Building old-time-1.1.0.3...
Configuring regex-base-0.93.2...
Installed old-time-1.1.0.3
Building regex-base-0.93.2...
Configuring hslogger-1.2.10...
Installed regex-base-0.93.2
Building hslogger-1.2.10...
Installed hslogger-1.2.10
Configuring regex-posix-0.95.2...
Building regex-posix-0.95.2...
Installed text-1.2.2.1
Configuring parsec-3.1.11...
Building parsec-3.1.11...
Installed regex-posix-0.95.2
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Installed regex-compat-0.95.1
Installed parsec-3.1.11
Configuring MissingH-1.4.0.1...
Building MissingH-1.4.0.1...
Installed MissingH-1.4.0.1
Configuring ConfigFile-1.1.4...
Building ConfigFile-1.1.4...
Installed ConfigFile-1.1.4
Configuring darcs-buildpackage-0.5.11...
Building darcs-buildpackage-0.5.11...
Failed to install darcs-buildpackage-0.5.11
Build log ( /home/builder/.cabal/logs/darcs-buildpackage-0.5.11.log ):
cabal: Entering directory '/tmp/cabal-tmp-25284/darcs-buildpackage-0.5.11'
[1 of 1] Compiling Main             ( /tmp/cabal-tmp-25284/darcs-buildpackage-0.5.11/dist/setup/setup.hs, /tmp/cabal-tmp-25284/darcs-buildpackage-0.5.11/dist/setup/Main.o )
Linking /tmp/cabal-tmp-25284/darcs-buildpackage-0.5.11/dist/setup/setup ...
Configuring darcs-buildpackage-0.5.11...
Warning: No 'build-type' specified. If you do not need a custom Setup.hs or
./configure script then use 'build-type: Simple'.
Building darcs-buildpackage-0.5.11...
Preprocessing executable 'darcs-buildpackage' for darcs-buildpackage-0.5.11...

on the commandline: warning:
    -XOverlappingInstances is deprecated: instead use per-instance pragmas OVERLAPPING/OVERLAPPABLE/OVERLAPS
[1 of 1] Compiling Main             ( darcs-buildpackage.hs, dist/build/darcs-buildpackage/darcs-buildpackage-tmp/Main.o )

darcs-buildpackage.hs:7:1: error:
    Failed to load interface for ‘Config’
    It is a member of the hidden package ‘ghc-8.0.1.20161018’.
    Perhaps you need to add ‘ghc’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:9:1: error:
    Failed to load interface for ‘System.Directory’
    It is a member of the hidden package ‘directory-1.2.6.2’.
    Perhaps you need to add ‘directory’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:10:1: error:
    Failed to load interface for ‘Import’
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:11:1: error:
    Failed to load interface for ‘Logging’
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:13:1: error:
    Failed to load interface for ‘Utils’
    Perhaps you meant Util (needs flag -package-key ghc-8.0.1.20161018)
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:14:1: error:
    Failed to load interface for ‘Versions’
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:18:1: error:
    Failed to load interface for ‘Darcs’
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:20:1: error:
    Failed to load interface for ‘System.Cmd’
    It is a member of the hidden package ‘process-1.4.2.0’.
    Perhaps you need to add ‘process’ to the build-depends in your .cabal file.
    Use -v to see a list of the files searched for.

darcs-buildpackage.hs:22:1: error:
    Failed to load interface for ‘Mirrors’
    Use -v to see a list of the files searched for.
cabal: Leaving directory '/tmp/cabal-tmp-25284/darcs-buildpackage-0.5.11'
cabal: Error: some packages failed to install:
darcs-buildpackage-0.5.11 failed during the building phase. The exception was:
ExitFailure 1