Metadata revisions for deepseq-generics-0.2.0.0

Package maintainers and Hackage trustees are allowed to edit certain bits of package metadata after a release, without uploading a new tarball. Note that the tarball itself is never changed, just the metadata that is stored separately. For more information about metadata revisions, please refer to the Hackage Metadata Revisions FAQ.

No. Time User SHA256
-r6 2021-07-18T22:55:10Z jack 8268d27332d0f931e4e4c2b81a595b4e043a3e5669ef2a2f0af6e3ac65bb96e3
  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.15
    to
    >=4.5 && <4.16

  • Changed the library component's library dependency on 'ghc-prim' from

    >=0.2 && <0.7
    to
    >=0.2 && <0.8

-r5 2020-04-14T06:01:45Z HerbertValerioRiedel 2fd753057f7016c579a621adb7e9ff600d1d9e3aedfce0882d57654583fa0fc7
  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.14
    to
    >=4.5 && <4.15

  • Changed the library component's library dependency on 'ghc-prim' from

    >=0.2 && <0.6
    to
    >=0.2 && <0.7

-r4 2019-09-11T20:17:44Z HerbertValerioRiedel 31cef0b0b8366a65f81ba792eb19aceec5b5ebce0875926afe52e365b1d04824
  • Changed tested-with from

    ghc ==8.4.*: ghc ==8.2.*: ghc ==8.0.*: ghc ==7.10.*: ghc ==7.8.*: ghc ==7.6.*: ghc ==7.4.*
    to
    ghc ==8.8.*: ghc ==8.6.*: ghc ==8.4.*: ghc ==8.2.*: ghc ==8.0.*: ghc ==7.10.*: ghc ==7.8.*: ghc ==7.6.*: ghc ==7.4.*

  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.13
    to
    >=4.5 && <4.14

-r3 2018-09-23T22:09:14Z HerbertValerioRiedel 9ae5db7a426b828f58b635c8e5fd687b7959ff5364c6628520c1db539be9641c
  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.12
    to
    >=4.5 && <4.13

-r2 2018-03-14T08:17:07Z HerbertValerioRiedel 8b45accc99a62d30df8c8ef4e2798795ea03788610ed87b52b1c74c4916bd1de
  • Changed tested-with from

    ghc ==8.0.*: ghc ==7.10.*: ghc ==7.8.*: ghc ==7.6.*: ghc ==7.4.*
    to
    ghc ==8.4.*: ghc ==8.2.*: ghc ==8.0.*: ghc ==7.10.*: ghc ==7.8.*: ghc ==7.6.*: ghc ==7.4.*

  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.11
    to
    >=4.5 && <4.12

-r1 2017-05-12T15:59:13Z HerbertValerioRiedel 023d1de7ad38dc0f72f0e77c7620a036fc632a6ac5c07e9f9229a8834948b514
  • Changed the library component's library dependency on 'base' from

    >=4.5 && <4.10
    to
    >=4.5 && <4.11

  • Changed the test suite 'deepseq-generics-tests' component's library dependency on 'HUnit' from

    -any
    to
    >=1.2.5 && <1.7

  • Changed the test suite 'deepseq-generics-tests' component's library dependency on 'test-framework' from

    -any
    to
    >=0.6.1 && <0.9

  • Changed the test suite 'deepseq-generics-tests' component's library dependency on 'test-framework-hunit' from

    -any
    to
    >=0.2.2 && <0.9

-r0 2016-01-03T14:47:43Z HerbertValerioRiedel 5771a0f6683511e8bb2b08735098d0f95cb109c4d299b9de1f259be4c6f901b2