Build #2 for drunken-bishop-0.1.0.0

[all reports]

Package drunken-bishop-0.1.0.0
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2020-06-20 02:54:09.708979704 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: drunken-bishop-0.1.0.0 (user goal)
[__1] trying: pureMD5-2.1.3 (dependency of drunken-bishop)
[__2] trying: tagged-0.8.6 (dependency of pureMD5)
[__3] trying: tagged:+deepseq
[__4] next goal: deepseq (dependency of tagged +deepseq)
[__4] rejecting: deepseq-1.4.4.0/installed-1.4.4.0 (conflict: drunken-bishop
=> array>=0.5.4 && <0.6, deepseq => array==0.5.3.0/installed-0.5.3.0)
[__4] trying: deepseq-1.4.4.0
[__5] trying: template-haskell-2.14.0.0/installed-2.14.0.0 (dependency of
tagged)
[__6] next goal: pretty (dependency of template-haskell)
[__6] rejecting: pretty-1.1.3.6/installed-1.1.3.6 (conflict: deepseq==1.4.4.0,
pretty => deepseq==1.4.4.0/installed-1.4.4.0)
[__6] rejecting: pretty-1.1.3.6, pretty-1.1.3.5, pretty-1.1.3.4,
pretty-1.1.3.3, pretty-1.1.3.2, pretty-1.1.3.1, pretty-1.1.2.1,
pretty-1.1.2.0, pretty-1.1.1.3, pretty-1.1.1.2, pretty-1.1.1.1,
pretty-1.1.1.0, pretty-1.1.0.0, pretty-1.0.1.2, pretty-1.0.1.1,
pretty-1.0.1.0, pretty-1.0.0.0 (conflict: template-haskell =>
pretty==1.1.3.6/installed-1.1.3.6)
[__6] fail (backjumping, conflict set: deepseq, pretty, template-haskell)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: template-haskell, pretty, tagged,
base, crypto-api, deepseq, drunken-bishop, pureMD5, tagged:deepseq
Try running with --minimize-conflict-set to improve the error message.