Build #7 for epub-tools-1.1.0

[all reports]

Package epub-tools-1.1.0
Install BuildFailed
Docs NotTried
Tests NotTried
Time submitted 2016-12-26 14:48:41.279042 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, bytestring-0.10.8.1, directory-1.2.6.2, epub-metadata-4.5, filepath-1.4.1.0, mtl-2.2.1, process-1.4.2.0, zip-archive-0.3.0.5, base-4.9.0.0, directory-1.2.6.2, epub-metadata-4.5, mtl-2.2.1, regex-compat-0.95.1, base-4.9.0.0, directory-1.2.6.2, epub-metadata-4.5, filepath-1.4.1.0, mtl-2.2.1, regex-compat-0.95.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring digest-0.0.1.2...
Configuring hxt-charproperties-9.2.0.1...
Building digest-0.0.1.2...
Building hxt-charproperties-9.2.0.1...
Installed digest-0.0.1.2
Configuring mtl-2.2.1...
Building mtl-2.2.1...
Configuring old-locale-1.0.0.7...
Installed mtl-2.2.1
Configuring text-1.2.2.1...
Installed hxt-charproperties-9.2.0.1
Building old-locale-1.0.0.7...
Building text-1.2.2.1...
Configuring utf8-string-1.0.1.1...
Installed old-locale-1.0.0.7
Building utf8-string-1.0.1.1...
Configuring zlib-0.6.1.2...
Installed utf8-string-1.0.1.1
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring regex-base-0.93.2...
Building regex-base-0.93.2...
Configuring hxt-unicode-9.0.2.4...
Installed regex-base-0.93.2
Building hxt-unicode-9.0.2.4...
Configuring old-time-1.1.0.3...
Installed text-1.2.2.1
Installed hxt-unicode-9.0.2.4
Configuring regex-posix-0.95.2...
Building old-time-1.1.0.3...
Building regex-posix-0.95.2...
Configuring parsec-3.1.11...
Installed old-time-1.1.0.3
Building parsec-3.1.11...
Installed regex-posix-0.95.2
Configuring regex-compat-0.95.1...
Building regex-compat-0.95.1...
Configuring zip-archive-0.3.0.5...
Installed regex-compat-0.95.1
Building zip-archive-0.3.0.5...
Installed parsec-3.1.11
Configuring regex-tdfa-1.2.2...
Building regex-tdfa-1.2.2...
Configuring hxt-regex-xmlschema-9.2.0.3...
Installed zip-archive-0.3.0.5
Building hxt-regex-xmlschema-9.2.0.3...
Configuring network-uri-2.6.1.0...
Installed hxt-regex-xmlschema-9.2.0.3
Building network-uri-2.6.1.0...
Installed network-uri-2.6.1.0
Configuring hxt-9.3.1.16...
Building hxt-9.3.1.16...
Installed regex-tdfa-1.2.2
Configuring regex-compat-tdfa-0.95.1.4...
Building regex-compat-tdfa-0.95.1.4...
Installed regex-compat-tdfa-0.95.1.4
Installed hxt-9.3.1.16
Configuring epub-metadata-4.5...
Building epub-metadata-4.5...
Installed epub-metadata-4.5
Configuring epub-tools-1.1.0...
Building epub-tools-1.1.0...
Failed to install epub-tools-1.1.0
Build log ( /home/builder/.cabal/logs/epub-tools-1.1.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-17299/epub-tools-1.1.0'
Configuring epub-tools-1.1.0...
Building epub-tools-1.1.0...
Preprocessing executable 'epubmeta' for epub-tools-1.1.0...
[1 of 7] Compiling EpubTools.EpubMeta.Util ( src/EpubTools/EpubMeta/Util.hs, dist/build/epubmeta/epubmeta-tmp/EpubTools/EpubMeta/Util.o )

src/EpubTools/EpubMeta/Util.hs:12:1: warning: [-Wdeprecations]
    Module ‘Control.Monad.Error’ is deprecated:
      Use Control.Monad.Except instead

src/EpubTools/EpubMeta/Util.hs:15:14: warning: [-Wdeprecations]
    In the use of type constructor or class ‘ErrorT’
    (imported from Control.Monad.Error, but defined in transformers-0.5.2.0:Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"

src/EpubTools/EpubMeta/Util.hs:18:9: warning: [-Wdeprecations]
    In the use of ‘runErrorT’
    (imported from Control.Monad.Error, but defined in transformers-0.5.2.0:Control.Monad.Trans.Error):
    Deprecated: "Use Control.Monad.Trans.Except instead"
[2 of 7] Compiling EpubTools.EpubMeta.Opts ( src/EpubTools/EpubMeta/Opts.hs, dist/build/epubmeta/epubmeta-tmp/EpubTools/EpubMeta/Opts.o )
[3 of 7] Compiling EpubTools.EpubMeta.Import ( src/EpubTools/EpubMeta/Import.hs, dist/build/epubmeta/epubmeta-tmp/EpubTools/EpubMeta/Import.o )

src/EpubTools/EpubMeta/Import.hs:10:1: error:
    Failed to load interface for ‘Codec.Epub.Archive’
    Use -v to see a list of the files searched for.

src/EpubTools/EpubMeta/Import.hs:11:24: error:
    Module ‘Codec.Epub.IO’ does not export ‘opfContentsFromBS’
cabal: Leaving directory '/tmp/cabal-tmp-17299/epub-tools-1.1.0'
cabal: Error: some packages failed to install:
epub-tools-1.1.0 failed during the building phase. The exception was:
ExitFailure 1