Build #1 for fix-parser-simple-15320.1

[all reports]

Package fix-parser-simple-15320.1
Install DependencyFailed mmtl-0.1
Docs NotTried
Tests NotTried
Time submitted unknown
Compiler ghc-7.6.3
OS linux
Arch x86_64
Dependencies mmtl-0.1, base-4.6.0.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mmtl-0.1...
Building mmtl-0.1...
Preprocessing library mmtl-0.1...

Control/Monad/Cont.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Cont/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/List.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Reader/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Writer/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead
[ 1 of 18] Compiling Control.Monad.Writer.Class ( Control/Monad/Writer/Class.hs, dist/build/Control/Monad/Writer/Class.o )
[ 2 of 18] Compiling Control.Monad.State.Class ( Control/Monad/State/Class.hs, dist/build/Control/Monad/State/Class.o )
[ 3 of 18] Compiling Control.Monad.Reader.Class ( Control/Monad/Reader/Class.hs, dist/build/Control/Monad/Reader/Class.o )
[ 4 of 18] Compiling Control.Monad.Identity ( Control/Monad/Identity.hs, dist/build/Control/Monad/Identity.o )
[ 5 of 18] Compiling Control.Monad.Error.Class ( Control/Monad/Error/Class.hs, dist/build/Control/Monad/Error/Class.o )
[ 6 of 18] Compiling Control.Monad.Trans ( Control/Monad/Trans.hs, dist/build/Control/Monad/Trans.o )

Control/Monad/Trans.hs:27:1: Warning:
    The import of `System.IO' is redundant
      except perhaps to import instances from `System.IO'
    To import instances alone, use: import System.IO()
[ 7 of 18] Compiling Control.Monad.List ( Control/Monad/List.hs, dist/build/Control/Monad/List.o )
[ 8 of 18] Compiling Control.Monad.State.Lazy ( Control/Monad/State/Lazy.hs, dist/build/Control/Monad/State/Lazy.o )
[ 9 of 18] Compiling Control.Monad.State ( Control/Monad/State.hs, dist/build/Control/Monad/State.o )
[10 of 18] Compiling Control.Monad.Reader ( Control/Monad/Reader.hs, dist/build/Control/Monad/Reader.o )

Control/Monad/Reader.hs:73:10: Warning:
    Orphan instance: instance MonadReader r ((->) r)
[11 of 18] Compiling Control.Monad.State.Strict ( Control/Monad/State/Strict.hs, dist/build/Control/Monad/State/Strict.o )
[12 of 18] Compiling Control.Monad.Writer.Lazy ( Control/Monad/Writer/Lazy.hs, dist/build/Control/Monad/Writer/Lazy.o )
[13 of 18] Compiling Control.Monad.Writer ( Control/Monad/Writer.hs, dist/build/Control/Monad/Writer.o )
[14 of 18] Compiling Control.Monad.Writer.Strict ( Control/Monad/Writer/Strict.hs, dist/build/Control/Monad/Writer/Strict.o )
[15 of 18] Compiling Control.Monad.Cont.Class ( Control/Monad/Cont/Class.hs, dist/build/Control/Monad/Cont/Class.o )
[16 of 18] Compiling Control.Monad.Cont ( Control/Monad/Cont.hs, dist/build/Control/Monad/Cont.o )
[17 of 18] Compiling Control.Monad.Codensity ( Control/Monad/Codensity.hs, dist/build/Control/Monad/Codensity.o )
[18 of 18] Compiling Control.Monad.Error ( Control/Monad/Error.hs, dist/build/Control/Monad/Error.o )

Control/Monad/Error.hs:62:21: Not in scope: `catch'

Control/Monad/Error.hs:66:18: Not in scope: `catch'
Failed to install mmtl-0.1
cabal: Error: some packages failed to install:
fix-parser-simple-15320.1 depends on mmtl-0.1 which failed to install.
mmtl-0.1 failed during the building phase. The exception was:
ExitFailure 1