Build #4 for fix-parser-simple-15320.1

[all reports]

Package fix-parser-simple-15320.1
Install DependencyFailed mmtl-0.1
Docs NotTried
Tests NotTried
Time submitted 2015-11-17 16:12:21.200837 UTC
Compiler ghc-7.10.2
OS linux
Arch x86_64
Dependencies mmtl-0.1, base-4.8.1.0
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mmtl-0.1...
Building mmtl-0.1...
Preprocessing library mmtl-0.1...

Control/Monad/Cont.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Cont/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/List.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Reader/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Writer/Class.hs:1:12: Warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead
[ 1 of 18] Compiling Control.Monad.Writer.Class ( Control/Monad/Writer/Class.hs, dist/build/Control/Monad/Writer/Class.o )

Control/Monad/Writer/Class.hs:30:1: Warning:
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
[ 2 of 18] Compiling Control.Monad.State.Class ( Control/Monad/State/Class.hs, dist/build/Control/Monad/State/Class.o )
[ 3 of 18] Compiling Control.Monad.Reader.Class ( Control/Monad/Reader/Class.hs, dist/build/Control/Monad/Reader/Class.o )
[ 4 of 18] Compiling Control.Monad.Identity ( Control/Monad/Identity.hs, dist/build/Control/Monad/Identity.o )

Control/Monad/Identity.hs:90:10:
    No instance for (Applicative Identity)
      arising from the superclasses of an instance declaration
    In the instance declaration for ‘Monad Identity’
Failed to install mmtl-0.1
cabal: Error: some packages failed to install:
fix-parser-simple-15320.1 depends on mmtl-0.1 which failed to install.
mmtl-0.1 failed during the building phase. The exception was:
ExitFailure 1