Build #7 for fix-parser-simple-15320.1

[all reports]

Package fix-parser-simple-15320.1
Install DependencyFailed mmtl-0.1
Docs NotTried
Tests NotTried
Time submitted 2016-12-26 04:52:06.189403 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies base-4.9.0.0, mmtl-0.1
Flags none

Build log

[view raw]

Resolving dependencies...
Configuring mmtl-0.1...
Building mmtl-0.1...
Failed to install mmtl-0.1
Build log ( /home/builder/.cabal/logs/mmtl-0.1.log ):
cabal: Entering directory '/tmp/cabal-tmp-5553/mmtl-0.1'
Configuring mmtl-0.1...
Building mmtl-0.1...
Preprocessing library mmtl-0.1...

Control/Monad/Cont.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Cont/Class.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Error/Class.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/List.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Reader/Class.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead

Control/Monad/Writer/Class.hs:1:12: warning:
    -fallow-undecidable-instances is deprecated: use -XUndecidableInstances or pragma {-# LANGUAGE UndecidableInstances #-} instead
[ 1 of 18] Compiling Control.Monad.Writer.Class ( Control/Monad/Writer/Class.hs, dist/build/Control/Monad/Writer/Class.o )

Control/Monad/Writer/Class.hs:30:1: warning: [-Wunused-imports]
    The import of ‘Data.Monoid’ is redundant
      except perhaps to import instances from ‘Data.Monoid’
    To import instances alone, use: import Data.Monoid()
[ 2 of 18] Compiling Control.Monad.Trans ( Control/Monad/Trans.hs, dist/build/Control/Monad/Trans.o )

Control/Monad/Trans.hs:27:1: warning: [-Wunused-imports]
    The import of ‘System.IO’ is redundant
      except perhaps to import instances from ‘System.IO’
    To import instances alone, use: import System.IO()
[ 3 of 18] Compiling Control.Monad.State.Class ( Control/Monad/State/Class.hs, dist/build/Control/Monad/State/Class.o )
[ 4 of 18] Compiling Control.Monad.State.Lazy ( Control/Monad/State/Lazy.hs, dist/build/Control/Monad/State/Lazy.o )

Control/Monad/State/Lazy.hs:98:10: error:
    • No instance for (Applicative (State s))
        arising from the superclasses of an instance declaration
    • In the instance declaration for ‘Monad (State s)’

Control/Monad/State/Lazy.hs:175:10: error:
    • Could not deduce (Applicative (StateT s m))
        arising from the superclasses of an instance declaration
      from the context: Monad m
        bound by the instance declaration
        at Control/Monad/State/Lazy.hs:175:10-40
    • In the instance declaration for ‘Monad (StateT s m)’

Control/Monad/State/Lazy.hs:182:10: error:
    • Could not deduce (GHC.Base.Alternative (StateT s m))
        arising from the superclasses of an instance declaration
      from the context: MonadPlus m
        bound by the instance declaration
        at Control/Monad/State/Lazy.hs:182:10-48
    • In the instance declaration for ‘MonadPlus (StateT s m)’
cabal: Leaving directory '/tmp/cabal-tmp-5553/mmtl-0.1'
cabal: Error: some packages failed to install:
fix-parser-simple-15320.1 depends on mmtl-0.1 which failed to install.
mmtl-0.1 failed during the building phase. The exception was:
ExitFailure 1