genvalidity-hspec: Standard spec's for GenValidity instances

[ library, mit, testing ] [ Propose Tags ]

Note: There are companion packages for this library:

Versions [faq] 0.1.0.0, 0.1.0.1, 0.2.0.0, 0.2.0.1, 0.2.0.3, 0.2.0.4, 0.2.0.5, 0.3.0.0, 0.3.1.0, 0.4.0.0, 0.5.0.0, 0.6.0.0, 0.6.0.1, 0.6.0.2, 0.6.0.3, 0.6.1.0, 0.6.1.1, 0.6.2.0, 0.6.2.1, 0.6.2.2, 0.6.2.3, 0.7.0.0
Dependencies base (<5), genvalidity (==0.3.*), hspec (>=2.2 && <2.5), QuickCheck, validity (==0.3.*) [details]
License MIT
Copyright Copyright: (c) 2016 Tom Sydney Kerckhove
Author Tom Sydney Kerckhove
Maintainer syd.kerckhove@gmail.com
Revised Revision 2 made by Norfair at Tue Jan 24 11:04:19 UTC 2017
Category Testing
Home page https://github.com/NorfairKing/validity#readme
Source repo head: git clone https://github.com/NorfairKing/validity
Uploaded by Norfair at Thu Jan 19 20:41:02 UTC 2017
Distributions LTSHaskell:0.6.2.3, NixOS:0.7.0.0, Stackage:0.7.0.0
Downloads 4543 total (404 in the last 30 days)
Rating (no votes yet) [estimated by rule of succession]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2017-01-19 [all 1 reports]

Modules

[Index]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees