Build #3 for glirc-2.24

[all reports]

Package glirc-2.24
Install DependencyFailed hookup-0.1.1.0
Docs NotTried
Tests NotTried
Time submitted 2017-09-28 03:10:13.453680134 UTC
Compiler ghc-8.0.2
OS linux
Arch x86_64
Dependencies HsOpenSSL-0.11.4.11, async-2.1.1.1, attoparsec-0.13.2.0, base-4.9.1.0, base64-bytestring-1.0.0.1, bytestring-0.10.8.1, config-schema-0.5.0.0, config-value-0.6.3, containers-0.5.7.1, directory-1.3.0.0, filepath-1.4.1.1, free-4.12.4, gitrev-1.3.1, hashable-1.2.6.1, hookup-0.1.1.0, irc-core-2.3.0, kan-extensions-5.0.2, lens-4.15.4, network-2.6.3.2, process-1.4.3.0, regex-tdfa-1.2.2, semigroupoids-5.2.1, socks-0.5.5, split-0.2.3.2, stm-2.4.4.1, template-haskell-2.11.1.0, text-1.2.2.2, time-1.6.0.1, transformers-0.5.2.0, unix-2.7.2.1, unordered-containers-0.2.8.0, vector-0.12.0.1, vty-5.17.1, base-4.9.1.0, lens-4.15.4, text-1.2.2.2, vty-5.17.1
Flags none

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring base-compat-0.9.3...
Configuring base-orphans-0.6...
Building base-compat-0.9.3...
Building base-orphans-0.6...
Installed base-orphans-0.6
Configuring base64-bytestring-1.0.0.1...
Building base64-bytestring-1.0.0.1...
Installed base-compat-0.9.3
Configuring cabal-doctest-1.0.2...
Building cabal-doctest-1.0.2...
Configuring call-stack-0.1.0...
Installed base64-bytestring-1.0.0.1
Building call-stack-0.1.0...
Installed cabal-doctest-1.0.2
Configuring fail-4.9.0.0...
Building fail-4.9.0.0...
Configuring cereal-0.5.4.0...
Installed call-stack-0.1.0
Configuring integer-logarithms-1.0.2...
Installed fail-4.9.0.0
Building cereal-0.5.4.0...
Building integer-logarithms-1.0.2...
Configuring microlens-0.4.8.1...
Installed integer-logarithms-1.0.2
Building microlens-0.4.8.1...
Configuring mtl-2.2.1...
Installed microlens-0.4.8.1
Configuring network-2.6.3.2...
Installed cereal-0.5.4.0
Building mtl-2.2.1...
Building network-2.6.3.2...
Configuring parallel-3.2.1.1...
Installed mtl-2.2.1
Building parallel-3.2.1.1...
Configuring primitive-0.6.2.0...
Installed parallel-3.2.1.1
Building primitive-0.6.2.0...
Configuring prelude-extras-0.4.0.3...
Installed network-2.6.3.2
Building prelude-extras-0.4.0.3...
Configuring reflection-2.1.2...
Installed primitive-0.6.2.0
Building reflection-2.1.2...
Configuring semigroups-0.18.3...
Installed prelude-extras-0.4.0.3
Building semigroups-0.18.3...
Configuring split-0.2.3.2...
Installed semigroups-0.18.3
Building split-0.2.3.2...
Configuring stm-2.4.4.1...
Installed split-0.2.3.2
Building stm-2.4.4.1...
Configuring text-1.2.2.2...
Installed reflection-2.1.2
Building text-1.2.2.2...
Configuring th-abstraction-0.2.6.0...
Installed stm-2.4.4.1
Building th-abstraction-0.2.6.0...
Configuring transformers-compat-0.5.1.4...
Installed th-abstraction-0.2.6.0
Building transformers-compat-0.5.1.4...
Configuring utf8-string-1.0.1.1...
Installed transformers-compat-0.5.1.4
Building utf8-string-1.0.1.1...
Configuring void-0.7.2...
Installed utf8-string-1.0.1.1
Building void-0.7.2...
Configuring gitrev-1.3.1...
Installed void-0.7.2
Building gitrev-1.3.1...
Installed text-1.2.2.2
Configuring microlens-th-0.4.1.1...
Building microlens-th-0.4.1.1...
Configuring regex-base-0.93.2...
Installed gitrev-1.3.1
Building regex-base-0.93.2...
Installed regex-base-0.93.2
Configuring HsOpenSSL-0.11.4.11...
Configuring socks-0.5.5...
Installed microlens-th-0.4.1.1
Building socks-0.5.5...
Building HsOpenSSL-0.11.4.11...
Configuring vector-0.12.0.1...
Installed socks-0.5.5
Building vector-0.12.0.1...
Warning: /tmp/pkgConf-HsOpenSSL-0.11.41600515282040332871.11: Unrecognized
field dynamic-library-dirs on line 40
Configuring StateVar-1.1.0.4...
Installed HsOpenSSL-0.11.4.11
Building StateVar-1.1.0.4...
Configuring async-2.1.1.1...
Installed StateVar-1.1.0.4
Building async-2.1.1.1...
Configuring exceptions-0.8.3...
Installed async-2.1.1.1
Building exceptions-0.8.3...
Configuring microlens-mtl-0.1.11.0...
Installed exceptions-0.8.3
Building microlens-mtl-0.1.11.0...
Configuring tagged-0.8.5...
Installed microlens-mtl-0.1.11.0
Building tagged-0.8.5...
Configuring config-value-0.6.3...
Installed tagged-0.8.5
Configuring blaze-builder-0.4.0.2...
Installed vector-0.12.0.1
Building config-value-0.6.3...
Building blaze-builder-0.4.0.2...
Configuring hashable-1.2.6.1...
Installed blaze-builder-0.4.0.2
Building hashable-1.2.6.1...
Configuring parsec-3.1.11...
Installed config-value-0.6.3
Building parsec-3.1.11...
Installed hashable-1.2.6.1
Configuring HsOpenSSL-x509-system-0.1.0.3...
Building HsOpenSSL-x509-system-0.1.0.3...
Installed HsOpenSSL-x509-system-0.1.0.3
Configuring contravariant-1.4...
Building contravariant-1.4...
Configuring distributive-0.5.3...
Installed parsec-3.1.11
Configuring scientific-0.3.5.2...
Installed contravariant-1.4
Building scientific-0.3.5.2...
Building distributive-0.5.3...
Warning: /tmp/pkgConf-distributive-0.51244316437971899228.3: Unrecognized
field dynamic-library-dirs on line 22
Configuring unordered-containers-0.2.8.0...
Installed distributive-0.5.3
Building unordered-containers-0.2.8.0...
Installed scientific-0.3.5.2
Configuring hookup-0.1.1.0...
Building hookup-0.1.1.0...
Failed to install hookup-0.1.1.0
Build log ( /home/builder/.cabal/logs/hookup-0.1.1.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-19281/hookup-0.1.1.0'
Configuring hookup-0.1.1.0...
Building hookup-0.1.1.0...
Preprocessing library hookup-0.1.1.0...
OpenSSL.hsc:14:2: error: #error "OpenSSL 1.0.2 or later is required. This version was released in Jan 2015 and adds hostname verification"
OpenSSL.hsc: In function ‘main’:
OpenSSL.hsc:14:2: error: #error "OpenSSL 1.0.2 or later is required. This version was released in Jan 2015 and adds hostname verification"
OpenSSL.hsc:14:2: error: #error "OpenSSL 1.0.2 or later is required. This version was released in Jan 2015 and adds hostname verification"
In file included from dist/build/Hookup/OpenSSL_hsc_make.c:1:0:
OpenSSL.hsc:59:16: error: ‘X509_CHECK_FLAG_NO_PARTIAL_WILDCARDS’ undeclared (first use in this function)
/opt/ghc/8.0.2/lib/ghc-8.0.2/template-hsc.h:35:10: note: in definition of macro ‘hsc_const’
     if ((x) < 0)                                      \
          ^
OpenSSL.hsc:59:16: note: each undeclared identifier is reported only once for each function it appears in
/opt/ghc/8.0.2/lib/ghc-8.0.2/template-hsc.h:35:10: note: in definition of macro ‘hsc_const’
     if ((x) < 0)                                      \
          ^
compiling dist/build/Hookup/OpenSSL_hsc_make.c failed (exit code 1)
command was: /usr/bin/gcc -c dist/build/Hookup/OpenSSL_hsc_make.c -o dist/build/Hookup/OpenSSL_hsc_make.o -fno-stack-protector -fno-stack-protector -D__GLASGOW_HASKELL__=800 -Dlinux_BUILD_OS=1 -Dx86_64_BUILD_ARCH=1 -Dlinux_HOST_OS=1 -Dx86_64_HOST_ARCH=1 -Idist/build/autogen -include dist/build/autogen/cabal_macros.h -I/home/builder/hackage-server/build-cache/tmp-install/lib/x86_64-linux-ghc-8.0.2/network-2.6.3.2-IsLM4TXcLoRI0fmmBYVyQz/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/unix-2.7.2.1/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/time-1.6.0.1/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/bytestring-0.10.8.1/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/base-4.9.1.0/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/integer-gmp-1.0.0.1/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/include -I/opt/ghc/8.0.2/lib/ghc-8.0.2/include/
cabal: Leaving directory '/tmp/cabal-tmp-19281/hookup-0.1.1.0'
Configuring regex-tdfa-1.2.2...
Building regex-tdfa-1.2.2...
Configuring vty-5.17.1...
Installed unordered-containers-0.2.8.0
Building vty-5.17.1...
Configuring comonad-5.0.2...
Installed regex-tdfa-1.2.2
Building comonad-5.0.2...
Warning: /tmp/pkgConf-comonad-5.019399644432112255763.2: Unrecognized field
dynamic-library-dirs on line 29
Configuring attoparsec-0.13.2.0...
Installed comonad-5.0.2
Building attoparsec-0.13.2.0...
Installed attoparsec-0.13.2.0
Configuring bifunctors-5.4.2...
Building bifunctors-5.4.2...
Installed bifunctors-5.4.2
Configuring profunctors-5.2.1...
Building profunctors-5.2.1...
Configuring irc-core-2.3.0...
Installed profunctors-5.2.1
Building irc-core-2.3.0...
Configuring semigroupoids-5.2.1...
Installed irc-core-2.3.0
Building semigroupoids-5.2.1...
Warning: /tmp/pkgConf-semigroupoids-5.26013856441172755590.1: Unrecognized
field dynamic-library-dirs on line 60
Installed semigroupoids-5.2.1
Configuring free-4.12.4...
Building free-4.12.4...
Installed free-4.12.4
Configuring adjunctions-4.3...
Building adjunctions-4.3...
Installed vty-5.17.1
Installed adjunctions-4.3
Configuring kan-extensions-5.0.2...
Building kan-extensions-5.0.2...
Installed kan-extensions-5.0.2
Configuring config-schema-0.5.0.0...
Configuring lens-4.15.4...
Building config-schema-0.5.0.0...
Building lens-4.15.4...
Installed config-schema-0.5.0.0
Warning: /tmp/pkgConf-lens-4.1514472676051369321801.4: Unrecognized field
dynamic-library-dirs on line 122
Installed lens-4.15.4
cabal: Error: some packages failed to install:
glirc-2.24 depends on hookup-0.1.1.0 which failed to install.
hookup-0.1.1.0 failed during the building phase. The exception was:
ExitFailure 1