Build #3 for hOpenPGP-2.5.3

[all reports]

Package hOpenPGP-2.5.3
Install DependencyFailed nettle-0.2.0
Docs NotTried
Tests NotTried
Time submitted 2016-11-19 23:17:16.992074 UTC
Compiler ghc-8.0.1.20161018
OS linux
Arch x86_64
Dependencies aeson-1.0.2.1, attoparsec-0.13.1.0, base-4.9.0.0, base64-bytestring-1.0.0.1, bifunctors-5.4.1, binary-0.8.3.0, binary-conduit-1.2.4.1, byteable-0.1.1, bytestring-0.10.8.1, bzlib-0.5.0.5, conduit-1.2.8, conduit-extra-1.1.15, containers-0.5.7.1, crypto-cipher-types-0.0.9, cryptonite-0.20, data-default-class-0.1.2.0, errors-2.1.2, hashable-1.2.4.0, incremental-parser-0.2.5, ixset-typed-0.3.1, lens-4.15.1, memory-0.13, monad-loops-0.4.3, nettle-0.2.0, network-2.6.3.1, network-uri-2.6.1.0, newtype-0.2, openpgp-asciiarmor-0.1, resourcet-1.1.8.1, securemem-0.1.9, semigroups-0.18.2, split-0.2.3.1, text-1.2.2.1, time-1.6.0.1, time-locale-compat-0.1.1.3, transformers-0.5.2.0, unordered-containers-0.2.7.1, wl-pprint-extras-3.5.0.5, zlib-0.6.1.2
Flags network-uri

Code Coverage

No Code Coverage was submitted for this report.

Build log

[view raw]

Resolving dependencies...
Configuring base-compat-0.9.1...
Configuring base-orphans-0.5.4...
Building base-orphans-0.5.4...
Building base-compat-0.9.1...
Installed base-orphans-0.5.4
Configuring base64-bytestring-1.0.0.1...
Building base64-bytestring-1.0.0.1...
Configuring byteable-0.1.1...
Installed base-compat-0.9.1
Building byteable-0.1.1...
Configuring cereal-0.5.4.0...
Installed base64-bytestring-1.0.0.1
Building cereal-0.5.4.0...
Configuring data-default-class-0.1.2.0...
Installed byteable-0.1.1
Building data-default-class-0.1.2.0...
Configuring dlist-0.8.0.2...
Installed data-default-class-0.1.2.0
Building dlist-0.8.0.2...
Configuring bzlib-0.5.0.5...
Installed cereal-0.5.4.0
Configuring monad-loops-0.4.3...
Installed dlist-0.8.0.2
Building bzlib-0.5.0.5...
Building monad-loops-0.4.3...
Configuring mtl-2.2.1...
Installed monad-loops-0.4.3
Building mtl-2.2.1...
Configuring memory-0.13...
Installed bzlib-0.5.0.5
Building memory-0.13...
Configuring nats-1.1.1...
Installed mtl-2.2.1
Building nats-1.1.1...
Configuring newtype-0.2...
Installed nats-1.1.1
Building newtype-0.2...
Configuring old-locale-1.0.0.7...
Installed newtype-0.2
Building old-locale-1.0.0.7...
Configuring parallel-3.2.1.0...
Installed memory-0.13
Building parallel-3.2.1.0...
Configuring prelude-extras-0.4.0.3...
Installed old-locale-1.0.0.7
Building prelude-extras-0.4.0.3...
Configuring primes-0.2.1.0...
Installed parallel-3.2.1.0
Building primes-0.2.1.0...
Configuring network-2.6.3.1...
Installed primes-0.2.1.0
Configuring primitive-0.6.1.0...
Installed prelude-extras-0.4.0.3
Building primitive-0.6.1.0...
Building network-2.6.3.1...
Configuring random-1.1...
Installed primitive-0.6.1.0
Building random-1.1...
Configuring reflection-2.1.2...
Installed random-1.1
Building reflection-2.1.2...
Configuring semigroups-0.18.2...
Installed network-2.6.3.1
Building semigroups-0.18.2...
Configuring split-0.2.3.1...
Installed semigroups-0.18.2
Building split-0.2.3.1...
Configuring safe-0.3.10...
Installed split-0.2.3.1
Building safe-0.3.10...
Configuring stm-2.4.4.1...
Installed reflection-2.1.2
Building stm-2.4.4.1...
Configuring syb-0.6...
Installed safe-0.3.10
Building syb-0.6...
Configuring time-locale-compat-0.1.1.3...
Installed stm-2.4.4.1
Building time-locale-compat-0.1.1.3...
Configuring text-1.2.2.1...
Installed time-locale-compat-0.1.1.3
Building text-1.2.2.1...
Configuring transformers-compat-0.5.1.4...
Installed syb-0.6
Building transformers-compat-0.5.1.4...
Configuring unexceptionalio-0.3.0...
Installed transformers-compat-0.5.1.4
Building unexceptionalio-0.3.0...
Configuring utf8-string-1.0.1.1...
Installed unexceptionalio-0.3.0
Building utf8-string-1.0.1.1...
Configuring zlib-0.6.1.2...
Installed utf8-string-1.0.1.1
Building zlib-0.6.1.2...
Installed zlib-0.6.1.2
Configuring securemem-0.1.9...
Building securemem-0.1.9...
Configuring old-time-1.1.0.3...
Installed text-1.2.2.1
Configuring cryptonite-0.20...
Installed securemem-0.1.9
Building old-time-1.1.0.3...
Building cryptonite-0.20...
Configuring StateVar-1.1.0.4...
Installed old-time-1.1.0.3
Building StateVar-1.1.0.4...
Configuring async-2.1.1...
Installed StateVar-1.1.0.4
Building async-2.1.1...
Configuring exceptions-0.8.3...
Installed async-2.1.1
Building exceptions-0.8.3...
Configuring mmorph-1.0.6...
Installed exceptions-0.8.3
Building mmorph-1.0.6...
Configuring vector-0.11.0.0...
Installed mmorph-1.0.6
Building vector-0.11.0.0...
Configuring tagged-0.8.5...
Installed cryptonite-0.20
Building tagged-0.8.5...
Configuring transformers-base-0.4.4...
Installed tagged-0.8.5
Building transformers-base-0.4.4...
Configuring errors-2.1.2...
Installed transformers-base-0.4.4
Building errors-2.1.2...
Installed vector-0.11.0.0
Configuring blaze-builder-0.4.0.2...
Building blaze-builder-0.4.0.2...
Configuring hashable-1.2.4.0...
Installed errors-2.1.2
Building hashable-1.2.4.0...
Configuring parsec-3.1.11...
Installed blaze-builder-0.4.0.2
Building parsec-3.1.11...
Configuring crypto-cipher-types-0.0.9...
Installed hashable-1.2.4.0
Building crypto-cipher-types-0.0.9...
Configuring distributive-0.5.0.2...
Installed crypto-cipher-types-0.0.9
Configuring monad-control-1.0.1.0...
Installed parsec-3.1.11
Building monad-control-1.0.1.0...
Building distributive-0.5.0.2...
Configuring monoid-subclasses-0.4.3...
Installed distributive-0.5.0.2
Configuring safecopy-0.9.2...
Installed monad-control-1.0.1.0
Building monoid-subclasses-0.4.3...
Building safecopy-0.9.2...
Installed safecopy-0.9.2
Configuring scientific-0.3.4.9...
Building scientific-0.3.4.9...
Configuring streaming-commons-0.1.16...
Installed scientific-0.3.4.9
Building streaming-commons-0.1.16...
Configuring void-0.7.1...
Installed monoid-subclasses-0.4.3
Building void-0.7.1...
Configuring unordered-containers-0.2.7.1...
Installed void-0.7.1
Building unordered-containers-0.2.7.1...
Configuring network-uri-2.6.1.0...
Installed streaming-commons-0.1.16
Building network-uri-2.6.1.0...
Configuring nettle-0.2.0...
Installed network-uri-2.6.1.0
Configuring lifted-base-0.2.3.8...
Failed to install nettle-0.2.0
Build log ( /home/builder/.cabal/logs/nettle-0.2.0.log ):
cabal: Entering directory '/tmp/cabal-tmp-11313/nettle-0.2.0'
Configuring nettle-0.2.0...
cabal: Missing dependency on a foreign library:
* Missing C library: nettle
This problem can usually be solved by installing the system package that
provides this library (you may need the "-dev" version). If the library is
already installed but in a non-standard location then you can use the flags
--extra-include-dirs= and --extra-lib-dirs= to specify where it is.
cabal: Leaving directory '/tmp/cabal-tmp-11313/nettle-0.2.0'
Configuring ixset-typed-0.3.1...
Installed unordered-containers-0.2.7.1
Building lifted-base-0.2.3.8...
Building ixset-typed-0.3.1...
Installed lifted-base-0.2.3.8
Configuring attoparsec-0.13.1.0...
Building attoparsec-0.13.1.0...
Configuring resourcet-1.1.8.1...
Installed ixset-typed-0.3.1
Building resourcet-1.1.8.1...
Configuring contravariant-1.4...
Installed resourcet-1.1.8.1
Building contravariant-1.4...
Configuring incremental-parser-0.2.5...
Installed attoparsec-0.13.1.0
Building incremental-parser-0.2.5...
Installed contravariant-1.4
Configuring conduit-1.2.8...
Building conduit-1.2.8...
Configuring openpgp-asciiarmor-0.1...
Installed incremental-parser-0.2.5
Building openpgp-asciiarmor-0.1...
Configuring comonad-5...
Installed openpgp-asciiarmor-0.1
Configuring aeson-1.0.2.1...
Installed conduit-1.2.8
Building comonad-5...
Building aeson-1.0.2.1...
Installed comonad-5
Configuring binary-conduit-1.2.4.1...
Building binary-conduit-1.2.4.1...
Installed binary-conduit-1.2.4.1
Configuring conduit-extra-1.1.15...
Building conduit-extra-1.1.15...
Configuring bifunctors-5.4.1...
Installed conduit-extra-1.1.15
Building bifunctors-5.4.1...
Installed aeson-1.0.2.1
Installed bifunctors-5.4.1
Configuring semigroupoids-5.1...
Configuring profunctors-5.2...
Building profunctors-5.2...
Building semigroupoids-5.1...
Installed profunctors-5.2
Installed semigroupoids-5.1
Configuring free-4.12.4...
Configuring wl-pprint-extras-3.5.0.5...
Building free-4.12.4...
Building wl-pprint-extras-3.5.0.5...
Installed wl-pprint-extras-3.5.0.5
Installed free-4.12.4
Configuring adjunctions-4.3...
Building adjunctions-4.3...
Installed adjunctions-4.3
Configuring kan-extensions-5.0.1...
Building kan-extensions-5.0.1...
Installed kan-extensions-5.0.1
Configuring lens-4.15.1...
Building lens-4.15.1...
Installed lens-4.15.1
cabal: Error: some packages failed to install:
hOpenPGP-2.5.3 depends on nettle-0.2.0 which failed to install.
nettle-0.2.0 failed during the configure step. The exception was:
ExitFailure 1