Build #3 for halma-gui-0.1.1.1

[all reports]

Package halma-gui-0.1.1.1
Install PlanningFailed
Docs NotTried
Tests NotTried
Time submitted 2019-01-03 13:11:50.529127976 UTC
Compiler ghc-8.6.3
OS linux
Arch x86_64
Dependencies
Flags none

Build log

[view raw]

Warning: The install command is a part of the legacy v1 style of cabal usage.

Please switch to using either the new project style and the new-install
command or the legacy v1-install alias as new-style projects will become the
default in the next version of cabal-install. Please file a bug if you cannot
replicate a working v1- use case with the new-style commands.

For more information, see: https://wiki.haskell.org/Cabal/NewBuild

Resolving dependencies...
cabal: Could not resolve dependencies:
[__0] trying: halma-gui-0.1.1.1 (user goal)
[__1] trying: pipes-4.3.9 (dependency of halma-gui)
[__2] trying: transformers-0.5.5.0/installed-0.5... (dependency of pipes)
[__3] trying: mvc-1.1.7 (dependency of halma-gui)
[__4] trying: pipes-concurrency-2.0.12 (dependency of mvc)
[__5] next goal: contravariant (dependency of mvc)
[__5] rejecting: contravariant-1.5 (conflict: mvc => contravariant<1.5)
[__5] rejecting: contravariant-1.4.1, contravariant-1.4 (conflict:
transformers => base==4.12.0.0/installed-4.1..., contravariant => base<4.12)
[__5] rejecting: contravariant-1.3.3 (conflict:
transformers==0.5.5.0/installed-0.5..., contravariant => transformers>=0.2 &&
<0.5)
[__5] rejecting: contravariant-1.3.2, contravariant-1.3.1.1,
contravariant-1.3.1, contravariant-1.3, contravariant-1.2.2.1,
contravariant-1.2.2, contravariant-1.2.1, contravariant-1.2.0.1,
contravariant-1.2, contravariant-1.1, contravariant-1.0,
contravariant-0.6.1.1, contravariant-0.6.1, contravariant-0.6,
contravariant-0.5.2, contravariant-0.5.1, contravariant-0.5,
contravariant-0.4.4, contravariant-0.4.3, contravariant-0.4.1,
contravariant-0.4, contravariant-0.3, contravariant-0.2.0.2,
contravariant-0.2.0.1, contravariant-0.2, contravariant-0.1.3,
contravariant-0.1.2.1, contravariant-0.1.2, contravariant-0.1.1,
contravariant-0.1.0.1, contravariant-0.1.0 (conflict: pipes-concurrency =>
contravariant>=1.3.3 && <1.6)
[__5] fail (backjumping, conflict set: contravariant, mvc, pipes-concurrency,
transformers)
After searching the rest of the dependency tree exhaustively, these were the
goals I've had most trouble fulfilling: pipes-concurrency, contravariant,
transformers, mvc, base, pipes, halma-gui