Build #1 for hasql-postgres-options-0.1.0

[all reports]

Package hasql-postgres-options-0.1.0
Install DependencyFailed uuid-1.3.5
Docs NotTried
Tests NotTried
Time submitted 2014-12-14 15:46:39.543275 UTC
Compiler ghc-7.8.3
OS linux
Arch x86_64
Dependencies optparse-applicative-0.11.0.1, hasql-postgres-0.8.0, bytestring-0.10.4.1, base-prelude-0.1.8, base-4.7.0.1
Flags none

Build log

[view raw]

Resolving dependencies...
In order, the following will be installed:
either-4.3.2 (new package)
hxt-9.3.1.9 (reinstall) changes: binary-0.7.2.2 -> 0.7.2.3
list-t-0.3.0 (new package)
hasql-backend-0.2.1 (new package)
opendatatable-0.0.0 (reinstall)
unix-time-0.3.4 (reinstall) changes: binary-0.7.2.2 -> 0.7.2.3
uuid-1.3.5 (new package)
postgresql-binary-0.5.0 (new package)
hasql-postgres-0.8.0 (new package)
hasql-postgres-options-0.1.0 (new package)
Warning: Note that reinstalls are always dangerous. Continuing anyway...
Configuring either-4.3.2...
Building either-4.3.2...
Preprocessing library either-4.3.2...

src/Control/Monad/Trans/Either.hs:39:8:
    Could not find module ‘Control.Monad.Free.Class’
    There are files missing in the ‘free-4.10.0.1’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Control/Monad/Trans/Either.hs:40:8:
    Could not find module ‘Control.Monad.Catch’
    There are files missing in the ‘exceptions-0.6.1’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Control/Monad/Trans/Either.hs:48:8:
    Could not find module ‘Control.Monad.Random’
    There are files missing in the ‘MonadRandom-0.3.0.1’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Control/Monad/Trans/Either.hs:51:8:
    Could not find module ‘Data.Functor.Bind’
    There are files missing in the ‘semigroupoids-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Control/Monad/Trans/Either.hs:52:8:
    Could not find module ‘Data.Functor.Plus’
    There are files missing in the ‘semigroupoids-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Either/Validation.hs:27:8:
    Could not find module ‘Data.Bifoldable’
    There are files missing in the ‘bifunctors-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Either/Validation.hs:28:8:
    Could not find module ‘Data.Bifunctor’
    There are files missing in the ‘bifunctors-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Either/Validation.hs:29:8:
    Could not find module ‘Data.Bitraversable’
    There are files missing in the ‘bifunctors-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Either/Validation.hs:31:8:
    Could not find module ‘Data.Functor.Alt’
    There are files missing in the ‘semigroupoids-4.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Either/Validation.hs:33:8:
    Could not find module ‘Data.Profunctor’
    There are files missing in the ‘profunctors-4.3.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
Failed to install either-4.3.2
Configuring hxt-9.3.1.9...
Building hxt-9.3.1.9...
Preprocessing library hxt-9.3.1.9...

src/Data/Atom.hs:68:18:
    Could not find module ‘Data.String.UTF8Decoding’
    There are files missing in the ‘hxt-unicode-9.0.2.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Atom.hs:69:18:
    Could not find module ‘Data.String.Unicode’
    There are files missing in the ‘hxt-unicode-9.0.2.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Data/Tree/NTree/TypeDefs.hs:29:18:
    Could not find module ‘Data.Binary’
    There are files missing in the ‘binary-0.7.2.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Text/XML/HXT/Arrow/Edit.hs:73:18:
    Could not find module ‘Data.Char.Properties.XMLCharProps’
    There are files missing in the ‘hxt-charproperties-9.2.0.0’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

src/Text/XML/HXT/DOM/Interface.hs:34:8:
    Could not find module ‘Data.String.EncodingNames’
    There are files missing in the ‘hxt-unicode-9.0.2.2’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
Failed to install hxt-9.3.1.9
Configuring list-t-0.3.0...
Building list-t-0.3.0...
Preprocessing library list-t-0.3.0...

library/ListT.hs:38:8:
    Could not find module ‘BasePrelude’
    There are files missing in the ‘base-prelude-0.1.8’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

library/ListT.hs:39:8:
    Could not find module ‘Control.Monad.Morph’
    There are files missing in the ‘mmorph-1.0.4’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
Failed to install list-t-0.3.0
Configuring unix-time-0.3.4...
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking xlocale.h usability... yes
checking xlocale.h presence... yes
checking for xlocale.h... yes
checking for strptime_l... yes
checking for timegm... yes
configure: creating ./config.status
config.status: creating cbits/config.h
Building unix-time-0.3.4...
Preprocessing library unix-time-0.3.4...

Data/UnixTime/Conv.hs:20:8:
    Could not find module ‘System.Time’
    There are files missing in the ‘old-time-1.1.0.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UnixTime/Types.hsc:10:8:
    Could not find module ‘Data.Binary’
    There are files missing in the ‘binary-0.7.2.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
Failed to install unix-time-0.3.4
Configuring uuid-1.3.5...
Building uuid-1.3.5...
Preprocessing library uuid-1.3.5...

Data/UUID/Internal.hs:56:8:
    Could not find module ‘Data.Binary’
    There are files missing in the ‘binary-0.7.2.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UUID/Internal.hs:57:8:
    Could not find module ‘Data.Binary.Put’
    There are files missing in the ‘binary-0.7.2.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UUID/Internal.hs:58:8:
    Could not find module ‘Data.Binary.Get’
    There are files missing in the ‘binary-0.7.2.3’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UUID/Util.hs:16:8:
    Could not find module ‘Network.Info’
    There are files missing in the ‘network-info-0.2.0.5’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UUID/V3.hs:38:18:
    Could not find module ‘Crypto.Hash.MD5’
    There are files missing in the ‘cryptohash-0.11.6’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.

Data/UUID/V5.hs:33:18:
    Could not find module ‘Crypto.Hash.SHA1’
    There are files missing in the ‘cryptohash-0.11.6’ package,
    try running 'ghc-pkg check'.
    Use -v to see a list of the files searched for.
Failed to install uuid-1.3.5
cabal: Error: some packages failed to install:
either-4.3.2 failed during the building phase. The exception was:
ExitFailure 1
hasql-backend-0.2.1 depends on list-t-0.3.0 which failed to install.
hasql-postgres-0.8.0 depends on uuid-1.3.5 which failed to install.
hasql-postgres-options-0.1.0 depends on uuid-1.3.5 which failed to install.
hxt-9.3.1.9 failed during the building phase. The exception was:
ExitFailure 1
list-t-0.3.0 failed during the building phase. The exception was:
ExitFailure 1
opendatatable-0.0.0 depends on hxt-9.3.1.9 which failed to install.
postgresql-binary-0.5.0 depends on uuid-1.3.5 which failed to install.
unix-time-0.3.4 failed during the building phase. The exception was:
ExitFailure 1
uuid-1.3.5 failed during the building phase. The exception was:
ExitFailure 1